CVE-2008-3747
The (1) get_edit_post_link and (2) get_edit_comment_link functions in wp-includes/link-template...
The (1) get_edit_post_link and (2) get_edit_comment_link functions in wp-includes/link-template.php in WordPress before 2.6.1 do not force SSL communication in the intended situations, which might allow remote attackers to gain administrative access by sniffing the network for a cookie.
Exploit likelihood
What each source reports
NVD Score used
7.5
The (1) get_edit_post_link and (2) get_edit_comment_link functions in wp-includes/link-template.php in WordPress before 2.6.1 do not force SSL communication in the intended situations, which might allow remote attackers to gain administrative access by sniffing the network for a cookie.
- Record
CVE-2008-3747- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-264
- Updated
- 2026-11-02
CVE List No score
The (1) get_edit_post_link and (2) get_edit_comment_link functions in wp-includes/link-template.php in WordPress before 2.6.1 do not force SSL communication in the intended situations, which might allow remote attackers to gain administrative access by sniffing the network for a cookie.
- Record
CVE-2008-3747- Updated
- 2026-11-02
EUVDEUVD-2008-3733 No score
The (1) get_edit_post_link and (2) get_edit_comment_link functions in wp-includes/link-template.php in WordPress before 2.6.1 do not force SSL communication in the intended situations, which might allow remote attackers to gain administrative access by sniffing the network for a cookie.
- Record
EUVD-2008-3733- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-f6wq-25v5-wmh5 No score
The (1) get_edit_post_link and (2) get_edit_comment_link functions in wp-includes/link-template...
The (1) get_edit_post_link and (2) get_edit_comment_link functions in wp-includes/link-template.php in WordPress before 2.6.1 do not force SSL communication in the intended situations, which might allow remote attackers to gain administrative access by sniffing the network for a cookie.
- Record
GHSA-f6wq-25v5-wmh5- Updated
- 2026-11-02
OSV No score
The (1) get_edit_post_link and (2) get_edit_comment_link functions in wp-includes/link-template.php in WordPress before 2.6.1 do not force SSL communication in the intended situations, which might allow remote attackers to gain administrative access by sniffing the network for a cookie.
- Record
CVE-2008-3747- Updated
- 2026-11-02
OSVDEBIAN-CVE-2008-3747 No score
The (1) get_edit_post_link and (2) get_edit_comment_link functions in wp-includes/link-template.php in WordPress before 2.6.1 do not force SSL communication in the intended situations, which might allow remote attackers to gain administrative access by sniffing the network for a cookie.
- Record
DEBIAN-CVE-2008-3747- Updated
- 2026-11-02
Affected products
Affected packages
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2008-3747 is a high vulnerability (CVSS 7.5) in Wordpress, published August 27, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.55%, the 85th percentile. Fixed in wordpress 2.5.1-6.
References
trac.wordpress.org/ticket/7359
openwall.com/lists/oss-security/2008/08/20/3
exchange.xforce.ibmcloud.com/vulnerabilities/44569
securityfocus.com/bid/30750
openwall.com/lists/oss-security/2008/08/19/1
nvd.nist.gov/vuln/detail/CVE-2008-3747
github.com/advisories/GHSA-f6wq-25v5-wmh5
security-tracker.debian.org/tracker/CVE-2008-3747