Every CVE Search/ Get API key

CVE-2008-4539

Heap-based buffer overflow in the Cirrus VGA implementation in (1) KVM before kvm-82 and (2) QEMU...

7.2 HighFix available

Heap-based buffer overflow in the Cirrus VGA implementation in (1) KVM before kvm-82 and (2) QEMU on Debian GNU/Linux and Ubuntu might allow local users to gain privileges by using the VNC console for a connection, aka the LGD-54XX "bitblt" heap overflow. NOTE: this issue exists because of an incorrect fix for CVE-2007-1320.

Exploit likelihood

0.54%Down 1.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.2

Heap-based buffer overflow in the Cirrus VGA implementation in (1) KVM before kvm-82 and (2) QEMU on Debian GNU/Linux and Ubuntu might allow local users to gain privileges by using the VNC console for a connection, aka the LGD-54XX "bitblt" heap overflow. NOTE: this issue exists because of an incorrect fix for CVE-2007-1320.

Record
CVE-2008-4539
CVSS 2.0
7.2 HighAV:L/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Heap-based buffer overflow in the Cirrus VGA implementation in (1) KVM before kvm-82 and (2) QEMU on Debian GNU/Linux and Ubuntu might allow local users to gain privileges by using the VNC console for a connection, aka the LGD-54XX "bitblt" heap overflow. NOTE: this issue exists because of an incorrect fix for CVE-2007-1320.

Record
CVE-2008-4539
Updated
2026-11-02
EUVDEUVD-2008-4520 No score

Heap-based buffer overflow in the Cirrus VGA implementation in (1) KVM before kvm-82 and (2) QEMU on Debian GNU/Linux and Ubuntu might allow local users to gain privileges by using the VNC console for a connection, aka the LGD-54XX "bitblt" heap overflow. NOTE: this issue exists because of an incorrect fix for CVE-2007-1320.

Record
EUVD-2008-4520
Updated
2026-11-03
GitHub AdvisoriesGHSA-gq7c-3rjh-ggvh No score

Heap-based buffer overflow in the Cirrus VGA implementation in (1) KVM before kvm-82 and (2) QEMU...

Heap-based buffer overflow in the Cirrus VGA implementation in (1) KVM before kvm-82 and (2) QEMU on Debian GNU/Linux and Ubuntu might allow local users to gain privileges by using the VNC console for a connection, aka the LGD-54XX "bitblt" heap overflow. NOTE: this issue exists because of an incorrect fix for CVE-2007-1320.

Record
GHSA-gq7c-3rjh-ggvh
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Heap-based buffer overflow in the Cirrus VGA implementation in (1) KVM before kvm-82 and (2) QEMU on Debian GNU/Linux and Ubuntu might allow local users to gain privileges by using the VNC console for a connection, aka the LGD-54XX "bitblt" heap overflow. NOTE: this issue exists because of an incorrect fix for CVE-2007-1320.

Record
CVE-2008-4539
Updated
2026-11-02
OSVDEBIAN-CVE-2008-4539 No score

Heap-based buffer overflow in the Cirrus VGA implementation in (1) KVM before kvm-82 and (2) QEMU on Debian GNU/Linux and Ubuntu might allow local users to gain privileges by using the VNC console for a connection, aka the LGD-54XX "bitblt" heap overflow. NOTE: this issue exists because of an incorrect fix for CVE-2007-1320.

Record
DEBIAN-CVE-2008-4539
Updated
2026-11-02
OSVopenSUSE-SU-2024:10233-1 No score

qemu-2.6.1-1.5 on GA media

These are all security issues fixed in the qemu-2.6.1-1.5 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10233-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:10285-1 No score

qemu-linux-user-2.6.1-1.5 on GA media

These are all security issues fixed in the qemu-linux-user-2.6.1-1.5 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10285-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
qemu
Debian:12
before 0.9.1+svn20081101-1
0.9.1+svn20081101-1
qemu
Debian:13
before 0.9.1+svn20081101-1
0.9.1+svn20081101-1
qemu
Debian:14
before 0.9.1+svn20081101-1
0.9.1+svn20081101-1
qemu
Debian:4.0
From an advisory covering 3 CVEs
before 0.8.2-4etch3, plus listed versions
0.8.2-40.8.2-4etch10.8.2-4etch2
0.8.2-4etch3
qemu
Debian:5.0
From an advisory covering 3 CVEs
before 0.9.1-10lenny1, plus listed versions
0.9.1-100.9.1-10lenny1~bpo40+1
0.9.1-10lenny1
qemu
openSUSE:Tumbleweed
From an advisory covering 53 CVEs
before 2.6.1-1.5
2.6.1-1.5
qemu-linux-user
openSUSE:Tumbleweed
From an advisory covering 12 CVEs
before 2.6.1-1.5
2.6.1-1.5

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
aliases
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2008-4539 is a high vulnerability (CVSS 7.2) in Debian Linux, published December 29, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.54%, the 45th percentile. Fixed in qemu 0.9.1+svn20081101-1.

References

Show 73 moreShow less
MoveEnter Open