Every CVE Search/ Get API key

CVE-2008-5101

Buffer overflow in the BMP reader in OptiPNG 0.6 and 0.6.1 allows user-assisted attackers to...

9.3 HighFix available

Buffer overflow in the BMP reader in OptiPNG 0.6 and 0.6.1 allows user-assisted attackers to execute arbitrary code via a crafted BMP image, related to an "array overflow."

Exploit likelihood

3.99%Up 1.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.3

Buffer overflow in the BMP reader in OptiPNG 0.6 and 0.6.1 allows user-assisted attackers to execute arbitrary code via a crafted BMP image, related to an "array overflow."

Record
CVE-2008-5101
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Buffer overflow in the BMP reader in OptiPNG 0.6 and 0.6.1 allows user-assisted attackers to execute arbitrary code via a crafted BMP image, related to an "array overflow."

Record
CVE-2008-5101
Updated
2026-11-02
EUVDEUVD-2008-5080 No score

Buffer overflow in the BMP reader in OptiPNG 0.6 and 0.6.1 allows user-assisted attackers to execute arbitrary code via a crafted BMP image, related to an "array overflow."

Record
EUVD-2008-5080
Updated
2026-11-03
GitHub AdvisoriesGHSA-cjj9-29x7-jq96 No score

Buffer overflow in the BMP reader in OptiPNG 0.6 and 0.6.1 allows user-assisted attackers to...

Buffer overflow in the BMP reader in OptiPNG 0.6 and 0.6.1 allows user-assisted attackers to execute arbitrary code via a crafted BMP image, related to an "array overflow."

Record
GHSA-cjj9-29x7-jq96
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Buffer overflow in the BMP reader in OptiPNG 0.6 and 0.6.1 allows user-assisted attackers to execute arbitrary code via a crafted BMP image, related to an "array overflow."

Record
CVE-2008-5101
Updated
2026-11-02
OSVDEBIAN-CVE-2008-5101 No score

Buffer overflow in the BMP reader in OptiPNG 0.6 and 0.6.1 allows user-assisted attackers to execute arbitrary code via a crafted BMP image, related to an "array overflow."

Record
DEBIAN-CVE-2008-5101
Updated
2026-11-02
OSVopenSUSE-SU-2024:11131-1 No score

optipng-0.7.7-2.3 on GA media

These are all security issues fixed in the optipng-0.7.7-2.3 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11131-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
optipng
Debian:12
before 0.6.1.1-1
0.6.1.1-1
optipng
Debian:13
before 0.6.1.1-1
0.6.1.1-1
optipng
Debian:14
before 0.6.1.1-1
0.6.1.1-1
optipng
openSUSE:Tumbleweed
From an advisory covering 3 CVEs
before 0.7.7-2.3
0.7.7-2.3

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2008-5101 is a high vulnerability (CVSS 9.3) in Optipng, published November 17, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.99%, the 90th percentile. Fixed in optipng 0.6.1.1-1.

References

Show 12 moreShow less
MoveEnter Open