Every CVE Search/ Get API key

CVE-2008-6679

Buffer overflow in the BaseFont writer module in Ghostscript 8.62, and possibly other versions,...

5.0 MediumFix available

Buffer overflow in the BaseFont writer module in Ghostscript 8.62, and possibly other versions, allows remote attackers to cause a denial of service (ps2pdf crash) and possibly execute arbitrary code via a crafted Postscript file.

Exploit likelihood

4.50%Down 3.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

Buffer overflow in the BaseFont writer module in Ghostscript 8.62, and possibly other versions, allows remote attackers to cause a denial of service (ps2pdf crash) and possibly execute arbitrary code via a crafted Postscript file.

Record
CVE-2008-6679
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Buffer overflow in the BaseFont writer module in Ghostscript 8.62, and possibly other versions, allows remote attackers to cause a denial of service (ps2pdf crash) and possibly execute arbitrary code via a crafted Postscript file.

Record
CVE-2008-6679
Updated
2026-11-02
EUVDEUVD-2008-6641 No score

Buffer overflow in the BaseFont writer module in Ghostscript 8.62, and possibly other versions, allows remote attackers to cause a denial of service (ps2pdf crash) and possibly execute arbitrary code via a crafted Postscript file.

Record
EUVD-2008-6641
Updated
2026-11-03
GitHub AdvisoriesGHSA-6p24-mjw7-mgwh No score

Buffer overflow in the BaseFont writer module in Ghostscript 8.62, and possibly other versions,...

Buffer overflow in the BaseFont writer module in Ghostscript 8.62, and possibly other versions, allows remote attackers to cause a denial of service (ps2pdf crash) and possibly execute arbitrary code via a crafted Postscript file.

Record
GHSA-6p24-mjw7-mgwh
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Buffer overflow in the BaseFont writer module in Ghostscript 8.62, and possibly other versions, allows remote attackers to cause a denial of service (ps2pdf crash) and possibly execute arbitrary code via a crafted Postscript file.

Record
CVE-2008-6679
Updated
2026-11-02
OSVDEBIAN-CVE-2008-6679 No score

Buffer overflow in the BaseFont writer module in Ghostscript 8.62, and possibly other versions, allows remote attackers to cause a denial of service (ps2pdf crash) and possibly execute arbitrary code via a crafted Postscript file.

Record
DEBIAN-CVE-2008-6679
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ghostscript
Debian:12
before 8.64~dfsg-1
8.64~dfsg-1
ghostscript
Debian:13
before 8.64~dfsg-1
8.64~dfsg-1
ghostscript
Debian:14
before 8.64~dfsg-1
8.64~dfsg-1
ghostscript
Debian:5.0
before 8.62.dfsg.1-3.2lenny4, plus listed versions
8.62.dfsg.1-3.2lenny08.62.dfsg.1-3.2lenny18.62.dfsg.1-3.2lenny2
8.62.dfsg.1-3.2lenny4
ghostscript
Red Hat:enterprise_linux:5::client_workstation
before 0:8.15.2-9.4.el5_3.7
0:8.15.2-9.4.el5_3.7
ghostscript-debuginfo
Red Hat:enterprise_linux:5::client_workstation
before 0:8.15.2-9.4.el5_3.7
0:8.15.2-9.4.el5_3.7
ghostscript-devel
Red Hat:enterprise_linux:5::client_workstation
before 0:8.15.2-9.4.el5_3.7
0:8.15.2-9.4.el5_3.7
ghostscript
Red Hat:enterprise_linux:5::client
before 0:8.15.2-9.4.el5_3.7
0:8.15.2-9.4.el5_3.7
ghostscript-debuginfo
Red Hat:enterprise_linux:5::client
before 0:8.15.2-9.4.el5_3.7
0:8.15.2-9.4.el5_3.7
ghostscript-gtk
Red Hat:enterprise_linux:5::client
before 0:8.15.2-9.4.el5_3.7
0:8.15.2-9.4.el5_3.7
Show 4 moreShow less
Affected packages
PackageAffectedFixed
ghostscript
Red Hat:enterprise_linux:5::server
before 0:8.15.2-9.4.el5_3.7
0:8.15.2-9.4.el5_3.7
ghostscript-debuginfo
Red Hat:enterprise_linux:5::server
before 0:8.15.2-9.4.el5_3.7
0:8.15.2-9.4.el5_3.7
ghostscript-devel
Red Hat:enterprise_linux:5::server
before 0:8.15.2-9.4.el5_3.7
0:8.15.2-9.4.el5_3.7
ghostscript-gtk
Red Hat:enterprise_linux:5::server
before 0:8.15.2-9.4.el5_3.7
0:8.15.2-9.4.el5_3.7

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2008-6679 is a medium vulnerability (CVSS 5.0) in Ghostscript, published April 8, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.50%, the 91st percentile. Fixed in ghostscript 8.64~dfsg-1.

References

Show 34 moreShow less
MoveEnter Open