Every CVE Search/ Get API key

CVE-2008-7313

The _httpsrequest function in Snoopy allows remote attackers to execute arbitrary commands. NOTE...

9.8 CriticalFix available

The _httpsrequest function in Snoopy allows remote attackers to execute arbitrary commands. NOTE: this issue exists dues to an incomplete fix for CVE-2008-4796.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

4.54%Up 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

The _httpsrequest function in Snoopy allows remote attackers to execute arbitrary commands. NOTE: this issue exists dues to an incomplete fix for CVE-2008-4796.

Record
CVE-2008-7313
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-77
Updated
2026-11-02
CVE List No score

The _httpsrequest function in Snoopy allows remote attackers to execute arbitrary commands. NOTE: this issue exists dues to an incomplete fix for CVE-2008-4796.

Record
CVE-2008-7313
Updated
2026-11-02
EUVDEUVD-2008-7264 No score

The _httpsrequest function in Snoopy allows remote attackers to execute arbitrary commands. NOTE: this issue exists dues to an incomplete fix for CVE-2008-4796.

Record
EUVD-2008-7264
Updated
2026-11-03
GitHub AdvisoriesGHSA-wr36-qh3g-7h4v 9.8

The _httpsrequest function in Snoopy allows remote attackers to execute arbitrary commands. NOTE...

The _httpsrequest function in Snoopy allows remote attackers to execute arbitrary commands. NOTE: this issue exists dues to an incomplete fix for CVE-2008-4796.

Record
GHSA-wr36-qh3g-7h4v
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-77
Updated
2026-11-02
OSV 9.8

The _httpsrequest function in Snoopy allows remote attackers to execute arbitrary commands. NOTE: this issue exists dues to an incomplete fix for CVE-2008-4796.

Record
CVE-2008-7313
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2008-7313 9.8

The _httpsrequest function in Snoopy allows remote attackers to execute arbitrary commands. NOTE: this issue exists dues to an incomplete fix for CVE-2008-4796.

Record
DEBIAN-CVE-2008-7313
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 5 moreShow less
OSVRHSA-2017:0211 8.1

Red Hat Security Advisory: nagios security update

Record
RHSA-2017:0211
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVRHSA-2017:0212 8.1

Red Hat Security Advisory: nagios security update

Record
RHSA-2017:0212
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVRHSA-2017:0213 8.1

Red Hat Security Advisory: nagios security update

Record
RHSA-2017:0213
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVRHSA-2017:0214 8.1

Red Hat Security Advisory: nagios security update

Record
RHSA-2017:0214
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2008-7313 9.8

The _httpsrequest function in Snoopy allows remote attackers to execute arbitrary commands. NOTE: this issue exists dues to an incomplete fix for CVE-2008-4796.

Record
UBUNTU-CVE-2008-7313
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libphp-snoopy
Debian:12
before 2.0.0-1
2.0.0-1
libphp-snoopy
Debian:6.0
From an advisory covering 2 CVEs
before 2.0.0-1~deb6u1, plus listed versions
1.2.4-2
2.0.0-1~deb6u1
libphp-snoopy
Debian:7
From an advisory covering 2 CVEs
before 2.0.0-1~deb7u1, plus listed versions
1.2.4-22.0.0-1~deb6u1
2.0.0-1~deb7u1
nagios
Red Hat:openstack:5::el7
From an advisory covering 5 CVEs
before 0:3.5.1-9.el7
0:3.5.1-9.el7
nagios-common
Red Hat:openstack:5::el7
From an advisory covering 5 CVEs
before 0:3.5.1-9.el7
0:3.5.1-9.el7
nagios-debuginfo
Red Hat:openstack:5::el7
From an advisory covering 5 CVEs
before 0:3.5.1-9.el7
0:3.5.1-9.el7
nagios-devel
Red Hat:openstack:5::el7
From an advisory covering 5 CVEs
before 0:3.5.1-9.el7
0:3.5.1-9.el7
nagios
Red Hat:openstack:5::el6
From an advisory covering 5 CVEs
before 0:3.5.1-9.el6
0:3.5.1-9.el6
nagios-common
Red Hat:openstack:5::el6
From an advisory covering 5 CVEs
before 0:3.5.1-9.el6
0:3.5.1-9.el6
nagios-debuginfo
Red Hat:openstack:5::el6
From an advisory covering 5 CVEs
before 0:3.5.1-9.el6
0:3.5.1-9.el6
Show 7 moreShow less
Affected packages
PackageAffectedFixed
nagios-devel
Red Hat:openstack:5::el6
From an advisory covering 5 CVEs
before 0:3.5.1-9.el6
0:3.5.1-9.el6
nagios
Red Hat:openstack:6::el7
From an advisory covering 5 CVEs
before 0:3.5.1-9.el7
0:3.5.1-9.el7
nagios-common
Red Hat:openstack:6::el7
From an advisory covering 5 CVEs
before 0:3.5.1-9.el7
0:3.5.1-9.el7
nagios-debuginfo
Red Hat:openstack:6::el7
From an advisory covering 5 CVEs
before 0:3.5.1-9.el7
0:3.5.1-9.el7
nagios
Red Hat:openstack:7::el7
From an advisory covering 5 CVEs
before 0:3.5.1-9.el7
0:3.5.1-9.el7
nagios-common
Red Hat:openstack:7::el7
From an advisory covering 5 CVEs
before 0:3.5.1-9.el7
0:3.5.1-9.el7
nagios-debuginfo
Red Hat:openstack:7::el7
From an advisory covering 5 CVEs
before 0:3.5.1-9.el7
0:3.5.1-9.el7

History

History
RecordedChangedSources
affected, facts
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2008-7313 is a critical vulnerability (CVSS 9.8) in Snoopy, published May 2, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.54%, the 91st percentile. Fixed in libphp-snoopy 2.0.0-1.

References

Show 38 moreShow less
MoveEnter Open