CVE-2008-7315
UI-Dialog 1.09 and earlier allows remote attackers to execute arbitrary commands.
UI-Dialog 1.09 and earlier allows remote attackers to execute arbitrary commands.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
UI-Dialog 1.09 and earlier allows remote attackers to execute arbitrary commands.
- Record
CVE-2008-7315- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-77
- Updated
- 2026-11-02
CVE List No score
UI-Dialog 1.09 and earlier allows remote attackers to execute arbitrary commands.
- Record
CVE-2008-7315- Updated
- 2026-11-02
EUVDEUVD-2008-7266 No score
UI-Dialog 1.09 and earlier allows remote attackers to execute arbitrary commands.
- Record
EUVD-2008-7266- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-3f84-j5xw-c967
9.8
UI-Dialog 1.09 and earlier allows remote attackers to execute arbitrary commands.
UI-Dialog 1.09 and earlier allows remote attackers to execute arbitrary commands.
- Record
GHSA-3f84-j5xw-c967- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-77
- Updated
- 2026-11-02
OSV
9.8
UI-Dialog 1.09 and earlier allows remote attackers to execute arbitrary commands.
- Record
CVE-2008-7315- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2008-7315
9.8
UI-Dialog 1.09 and earlier allows remote attackers to execute arbitrary commands.
- Record
DEBIAN-CVE-2008-7315- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2008-7315
9.8
UI-Dialog 1.09 and earlier allows remote attackers to execute arbitrary commands.
- Record
UBUNTU-CVE-2008-7315- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libui-dialog-perlDebian:12 |
before 1.21-0.1 | 1.21-0.1 |
libui-dialog-perlDebian:13 |
before 1.21-0.1 | 1.21-0.1 |
libui-dialog-perlDebian:14 |
before 1.21-0.1 | 1.21-0.1 |
libui-dialog-perlUbuntu:16.04:LTS |
All versions, plus listed versions 1.09-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2008-7315 is a critical vulnerability (CVSS 9.8) in Cpan Ui\, published October 10, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.43%, the 88th percentile. Fixed in libui-dialog-perl 1.21-0.1.