Every CVE Search/ Get API key

CVE-2009-0029

The ABI in the Linux kernel 2.6.28 and earlier on s390, powerpc, sparc64, and mips 64-bit...

7.2 HighFix available

The ABI in the Linux kernel 2.6.28 and earlier on s390, powerpc, sparc64, and mips 64-bit platforms requires that a 32-bit argument in a 64-bit register was properly sign extended when sent from a user-mode application, but cannot verify this, which allows local users to cause a denial of service (crash) or possibly gain privileges via a crafted system call.

Exploit likelihood

0.42%Down 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.2

The ABI in the Linux kernel 2.6.28 and earlier on s390, powerpc, sparc64, and mips 64-bit platforms requires that a 32-bit argument in a 64-bit register was properly sign extended when sent from a user-mode application, but cannot verify this, which allows local users to cause a denial of service (crash) or possibly gain privileges via a crafted system call.

Record
CVE-2009-0029
CVSS 2.0
7.2 HighAV:L/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

The ABI in the Linux kernel 2.6.28 and earlier on s390, powerpc, sparc64, and mips 64-bit platforms requires that a 32-bit argument in a 64-bit register was properly sign extended when sent from a user-mode application, but cannot verify this, which allows local users to cause a denial of service (crash) or possibly gain privileges via a crafted system call.

Record
CVE-2009-0029
Updated
2026-11-02
EUVDEUVD-2009-0041 No score

The ABI in the Linux kernel 2.6.28 and earlier on s390, powerpc, sparc64, and mips 64-bit platforms requires that a 32-bit argument in a 64-bit register was properly sign extended when sent from a user-mode application, but cannot verify this, which allows local users to cause a denial of service (crash) or possibly gain privileges via a crafted system call.

Record
EUVD-2009-0041
Updated
2026-11-03
GitHub AdvisoriesGHSA-4cr9-h3gm-wcrx No score

The ABI in the Linux kernel 2.6.28 and earlier on s390, powerpc, sparc64, and mips 64-bit...

The ABI in the Linux kernel 2.6.28 and earlier on s390, powerpc, sparc64, and mips 64-bit platforms requires that a 32-bit argument in a 64-bit register was properly sign extended when sent from a user-mode application, but cannot verify this, which allows local users to cause a denial of service (crash) or possibly gain privileges via a crafted system call.

Record
GHSA-4cr9-h3gm-wcrx
Weakness
CWE-20
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
linux-2.6
Debian:5.0
before 2.6.26-13lenny2, plus listed versions
2.6.26-132.6.26-13lenny2~bpo40+1
2.6.26-13lenny2
linux-2.6.24
Debian:4.0
before 2.6.24-6~etchnhalf.8etch1, plus listed versions
2.6.24-5~etchnhalf.12.6.24-6~etchnhalf.12.6.24-6~etchnhalf.22.6.24-6~etchnhalf.32.6.24-6~etchnhalf.4
Show 4 moreShow less
2.6.24-6~etchnhalf.52.6.24-6~etchnhalf.62.6.24-6~etchnhalf.72.6.24-6~etchnhalf.8
2.6.24-6~etchnhalf.8etch1
linux-2.6
Debian:4.0
before 2.6.18.dfsg.1-24etch2, plus listed versions
2.6.18.dfsg.1-122.6.18.dfsg.1-12etch12.6.18.dfsg.1-12etch22.6.18.dfsg.1-132.6.18.dfsg.1-13etch1
Show 28 moreShow less
2.6.18.dfsg.1-13etch22.6.18.dfsg.1-13etch32.6.18.dfsg.1-13etch42.6.18.dfsg.1-13etch52.6.18.dfsg.1-13etch62.6.18.dfsg.1-13lenny12.6.18.dfsg.1-142.6.18.dfsg.1-152.6.18.dfsg.1-162.6.18.dfsg.1-172.6.18.dfsg.1-17etch12.6.18.dfsg.1-182.6.18.dfsg.1-18etch12.6.18.dfsg.1-18etch32.6.18.dfsg.1-18etch42.6.18.dfsg.1-18etch52.6.18.dfsg.1-18etch62.6.18.dfsg.1-192.6.18.dfsg.1-202.6.18.dfsg.1-212.6.18.dfsg.1-222.6.18.dfsg.1-22etch12.6.18.dfsg.1-22etch22.6.18.dfsg.1-22etch32.6.18.dfsg.1-232.6.18.dfsg.1-23etch12.6.18.dfsg.1-242.6.18.dfsg.1-24etch1
2.6.18.dfsg.1-24etch2
fai-kernels
Debian:4.0
before 1.17+etch.24etch2, plus listed versions
1.171.17+etch.13etch31.17+etch.13etch41.17+etch.13etch51.17+etch.13etch6
Show 22 moreShow less
1.17+etch.161.17+etch.171.17+etch.17etch11.17+etch.18etch11.17+etch.18etch21.17+etch.18etch31.17+etch.18etch41.17+etch.18etch51.17+etch.18etch61.17+etch.211.17+etch.22etch11.17+etch.22etch21.17+etch.22etch31.17+etch.231.17+etch.23etch11.17+etch.241.17+etch11.17+etch21.17+etch31.17+etch41.17+etch51.17etch1
1.17+etch.24etch2
user-mode-linux
Debian:4.0
before 2.6.18-1um-2etch.24etch2, plus listed versions
2.6.18-1um-22.6.18-1um-2etch.13etch32.6.18-1um-2etch.13etch42.6.18-1um-2etch.13etch52.6.18-1um-2etch.13etch6
Show 20 moreShow less
2.6.18-1um-2etch.162.6.18-1um-2etch.172.6.18-1um-2etch.17etch12.6.18-1um-2etch.18etch12.6.18-1um-2etch.18etch22.6.18-1um-2etch.18etch32.6.18-1um-2etch.18etch42.6.18-1um-2etch.18etch52.6.18-1um-2etch.18etch62.6.18-1um-2etch.212.6.18-1um-2etch.22etch12.6.18-1um-2etch.22etch22.6.18-1um-2etch.22etch32.6.18-1um-2etch.232.6.18-1um-2etch.23etch12.6.18-1um-2etch.242.6.18-1um-2etch12.6.18-1um-2etch22.6.18-1um-2etch32.6.18-1um-2etch4
2.6.18-1um-2etch.24etch2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-0029 is a high vulnerability (CVSS 7.2) in Debian Linux, published January 15, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.42%, the 36th percentile. Fixed in linux-2.6 2.6.26-13lenny2.

References

Show 11 moreShow less
MoveEnter Open