Every CVE Search/ Get API key

CVE-2009-0196

Heap-based buffer overflow in the big2_decode_symbol_dict function (jbig2_symbol_dict.c) in the...

9.3 HighFix available

Heap-based buffer overflow in the big2_decode_symbol_dict function (jbig2_symbol_dict.c) in the JBIG2 decoding library (jbig2dec) in Ghostscript 8.64, and probably earlier versions, allows remote attackers to execute arbitrary code via a PDF file with a JBIG2 symbol dictionary segment with a large run length value.

Exploit likelihood

7.43%Down 2.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.3

Heap-based buffer overflow in the big2_decode_symbol_dict function (jbig2_symbol_dict.c) in the JBIG2 decoding library (jbig2dec) in Ghostscript 8.64, and probably earlier versions, allows remote attackers to execute arbitrary code via a PDF file with a JBIG2 symbol dictionary segment with a large run length value.

Record
CVE-2009-0196
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Heap-based buffer overflow in the big2_decode_symbol_dict function (jbig2_symbol_dict.c) in the JBIG2 decoding library (jbig2dec) in Ghostscript 8.64, and probably earlier versions, allows remote attackers to execute arbitrary code via a PDF file with a JBIG2 symbol dictionary segment with a large run length value.

Record
CVE-2009-0196
Updated
2026-11-02
EUVDEUVD-2009-0205 No score

Heap-based buffer overflow in the big2_decode_symbol_dict function (jbig2_symbol_dict.c) in the JBIG2 decoding library (jbig2dec) in Ghostscript 8.64, and probably earlier versions, allows remote attackers to execute arbitrary code via a PDF file with a JBIG2 symbol dictionary segment with a large run length value.

Record
EUVD-2009-0205
Updated
2026-11-03
GitHub AdvisoriesGHSA-76p8-fv4q-j2wv No score

Heap-based buffer overflow in the big2_decode_symbol_dict function (jbig2_symbol_dict.c) in the...

Heap-based buffer overflow in the big2_decode_symbol_dict function (jbig2_symbol_dict.c) in the JBIG2 decoding library (jbig2dec) in Ghostscript 8.64, and probably earlier versions, allows remote attackers to execute arbitrary code via a PDF file with a JBIG2 symbol dictionary segment with a large run length value.

Record
GHSA-76p8-fv4q-j2wv
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Heap-based buffer overflow in the big2_decode_symbol_dict function (jbig2_symbol_dict.c) in the JBIG2 decoding library (jbig2dec) in Ghostscript 8.64, and probably earlier versions, allows remote attackers to execute arbitrary code via a PDF file with a JBIG2 symbol dictionary segment with a large run length value.

Record
CVE-2009-0196
Updated
2026-11-02
OSVDEBIAN-CVE-2009-0196 No score

Heap-based buffer overflow in the big2_decode_symbol_dict function (jbig2_symbol_dict.c) in the JBIG2 decoding library (jbig2dec) in Ghostscript 8.64, and probably earlier versions, allows remote attackers to execute arbitrary code via a PDF file with a JBIG2 symbol dictionary segment with a large run length value.

Record
DEBIAN-CVE-2009-0196
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ghostscript
Debian:12
before 8.64~dfsg-1.1
8.64~dfsg-1.1
ghostscript
Debian:13
before 8.64~dfsg-1.1
8.64~dfsg-1.1
ghostscript
Debian:14
before 8.64~dfsg-1.1
8.64~dfsg-1.1
ghostscript
Debian:5.0
From an advisory covering 7 CVEs
before 8.62.dfsg.1-3.2lenny4, plus listed versions
8.62.dfsg.1-3.2lenny08.62.dfsg.1-3.2lenny18.62.dfsg.1-3.2lenny2
8.62.dfsg.1-3.2lenny4
ghostscript
Debian:6.0
From an advisory covering 4 CVEs
before 8.64~dfsg-1+squeeze1
8.64~dfsg-1+squeeze1
ghostscript
Red Hat:enterprise_linux:5::client_workstation
From an advisory covering 4 CVEs
before 0:8.15.2-9.4.el5_3.7
0:8.15.2-9.4.el5_3.7
ghostscript-debuginfo
Red Hat:enterprise_linux:5::client_workstation
From an advisory covering 4 CVEs
before 0:8.15.2-9.4.el5_3.7
0:8.15.2-9.4.el5_3.7
ghostscript-devel
Red Hat:enterprise_linux:5::client_workstation
From an advisory covering 4 CVEs
before 0:8.15.2-9.4.el5_3.7
0:8.15.2-9.4.el5_3.7
ghostscript
Red Hat:enterprise_linux:5::client
From an advisory covering 4 CVEs
before 0:8.15.2-9.4.el5_3.7
0:8.15.2-9.4.el5_3.7
ghostscript-debuginfo
Red Hat:enterprise_linux:5::client
From an advisory covering 4 CVEs
before 0:8.15.2-9.4.el5_3.7
0:8.15.2-9.4.el5_3.7
Show 5 moreShow less
Affected packages
PackageAffectedFixed
ghostscript-gtk
Red Hat:enterprise_linux:5::client
From an advisory covering 4 CVEs
before 0:8.15.2-9.4.el5_3.7
0:8.15.2-9.4.el5_3.7
ghostscript
Red Hat:enterprise_linux:5::server
From an advisory covering 4 CVEs
before 0:8.15.2-9.4.el5_3.7
0:8.15.2-9.4.el5_3.7
ghostscript-debuginfo
Red Hat:enterprise_linux:5::server
From an advisory covering 4 CVEs
before 0:8.15.2-9.4.el5_3.7
0:8.15.2-9.4.el5_3.7
ghostscript-devel
Red Hat:enterprise_linux:5::server
From an advisory covering 4 CVEs
before 0:8.15.2-9.4.el5_3.7
0:8.15.2-9.4.el5_3.7
ghostscript-gtk
Red Hat:enterprise_linux:5::server
From an advisory covering 4 CVEs
before 0:8.15.2-9.4.el5_3.7
0:8.15.2-9.4.el5_3.7

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-0196 is a high vulnerability (CVSS 9.3) in Ghostscript, published April 4, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 7.43%, the 94th percentile. Fixed in ghostscript 8.64~dfsg-1.1.

References

Show 42 moreShow less
MoveEnter Open