Every CVE Search/ Get API key

CVE-2009-0415

Untrusted search path vulnerability in trickle 1.07 allows local users to execute arbitrary code...

3.7 LowFix available

Untrusted search path vulnerability in trickle 1.07 allows local users to execute arbitrary code via a Trojan horse trickle-overload.so in the current working directory, which is referenced in the LD_PRELOAD path.

Exploit likelihood

0.46%Down 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 3.7

Untrusted search path vulnerability in trickle 1.07 allows local users to execute arbitrary code via a Trojan horse trickle-overload.so in the current working directory, which is referenced in the LD_PRELOAD path.

Record
CVE-2009-0415
CVSS 2.0
3.7 LowAV:L/AC:H/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Untrusted search path vulnerability in trickle 1.07 allows local users to execute arbitrary code via a Trojan horse trickle-overload.so in the current working directory, which is referenced in the LD_PRELOAD path.

Record
CVE-2009-0415
Updated
2026-11-02
EUVDEUVD-2009-0419 No score

Untrusted search path vulnerability in trickle 1.07 allows local users to execute arbitrary code via a Trojan horse trickle-overload.so in the current working directory, which is referenced in the LD_PRELOAD path.

Record
EUVD-2009-0419
Updated
2026-11-03
GitHub AdvisoriesGHSA-p5q7-3j52-5rg9 No score

Untrusted search path vulnerability in trickle 1.07 allows local users to execute arbitrary code...

Untrusted search path vulnerability in trickle 1.07 allows local users to execute arbitrary code via a Trojan horse trickle-overload.so in the current working directory, which is referenced in the LD_PRELOAD path.

Record
GHSA-p5q7-3j52-5rg9
Updated
2026-11-02
OSV No score

Untrusted search path vulnerability in trickle 1.07 allows local users to execute arbitrary code via a Trojan horse trickle-overload.so in the current working directory, which is referenced in the LD_PRELOAD path.

Record
CVE-2009-0415
Updated
2026-11-02
OSVDEBIAN-CVE-2009-0415 No score

Untrusted search path vulnerability in trickle 1.07 allows local users to execute arbitrary code via a Trojan horse trickle-overload.so in the current working directory, which is referenced in the LD_PRELOAD path.

Record
DEBIAN-CVE-2009-0415
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
trickle
Debian:12
before 1.07-6
1.07-6
trickle
Debian:13
before 1.07-6
1.07-6
trickle
Debian:14
before 1.07-6
1.07-6

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-0415 is a low vulnerability (CVSS 3.7) in Monkey Trickle, published February 3, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.46%, the 39th percentile. Fixed in trickle 1.07-6.

References

MoveEnter Open