Every CVE Search/ Get API key

CVE-2009-0579

Linux-PAM before 1.0.4 does not enforce the minimum password age (MINDAYS) as specified in /etc...

4.6 MediumFix available

Linux-PAM before 1.0.4 does not enforce the minimum password age (MINDAYS) as specified in /etc/shadow, which allows local users to bypass intended security policy and change their passwords sooner than specified.

Exploit likelihood

0.35%Down 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.6

Linux-PAM before 1.0.4 does not enforce the minimum password age (MINDAYS) as specified in /etc/shadow, which allows local users to bypass intended security policy and change their passwords sooner than specified.

Record
CVE-2009-0579
CVSS 2.0
4.6 MediumAV:L/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

Linux-PAM before 1.0.4 does not enforce the minimum password age (MINDAYS) as specified in /etc/shadow, which allows local users to bypass intended security policy and change their passwords sooner than specified.

Record
CVE-2009-0579
Updated
2026-11-02
EUVDEUVD-2009-0583 No score

Linux-PAM before 1.0.4 does not enforce the minimum password age (MINDAYS) as specified in /etc/shadow, which allows local users to bypass intended security policy and change their passwords sooner than specified.

Record
EUVD-2009-0583
Updated
2026-11-03
GitHub AdvisoriesGHSA-hm9c-qrxw-gvc3 No score

Linux-PAM before 1.0.4 does not enforce the minimum password age (MINDAYS) as specified in /etc...

Linux-PAM before 1.0.4 does not enforce the minimum password age (MINDAYS) as specified in /etc/shadow, which allows local users to bypass intended security policy and change their passwords sooner than specified.

Record
GHSA-hm9c-qrxw-gvc3
Updated
2026-11-02
OSV No score

Linux-PAM before 1.0.4 does not enforce the minimum password age (MINDAYS) as specified in /etc/shadow, which allows local users to bypass intended security policy and change their passwords sooner than specified.

Record
CVE-2009-0579
Updated
2026-11-02
OSVDEBIAN-CVE-2009-0579 No score

Linux-PAM before 1.0.4 does not enforce the minimum password age (MINDAYS) as specified in /etc/shadow, which allows local users to bypass intended security policy and change their passwords sooner than specified.

Record
DEBIAN-CVE-2009-0579
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pam
Debian:12
before 1.0.1-10
1.0.1-10
pam
Debian:13
before 1.0.1-10
1.0.1-10
pam
Debian:14
before 1.0.1-10
1.0.1-10

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-0579 is a medium vulnerability (CVSS 4.6) in Linux-pam, published April 16, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.35%, the 28th percentile. Fixed in pam 1.0.1-10.

References

Show 4 moreShow less
MoveEnter Open