Every CVE Search/ Get API key

CVE-2009-0723

Multiple integer overflows in LittleCMS (aka lcms or liblcms) before 1.18beta2, as used in...

9.3 HighFix available

Multiple integer overflows in LittleCMS (aka lcms or liblcms) before 1.18beta2, as used in Firefox 3.1beta, OpenJDK, and GIMP, allow context-dependent attackers to execute arbitrary code via a crafted image file that triggers a heap-based buffer overflow. NOTE: some of these details are obtained from third party information.

Exploit likelihood

5.03%Up 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.3

Multiple integer overflows in LittleCMS (aka lcms or liblcms) before 1.18beta2, as used in Firefox 3.1beta, OpenJDK, and GIMP, allow context-dependent attackers to execute arbitrary code via a crafted image file that triggers a heap-based buffer overflow. NOTE: some of these details are obtained from third party information.

Record
CVE-2009-0723
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-190
Updated
2026-11-02
CVE List No score

Multiple integer overflows in LittleCMS (aka lcms or liblcms) before 1.18beta2, as used in Firefox 3.1beta, OpenJDK, and GIMP, allow context-dependent attackers to execute arbitrary code via a crafted image file that triggers a heap-based buffer overflow. NOTE: some of these details are obtained from third party information.

Record
CVE-2009-0723
Updated
2026-11-02
EUVDEUVD-2009-0723 No score

Multiple integer overflows in LittleCMS (aka lcms or liblcms) before 1.18beta2, as used in Firefox 3.1beta, OpenJDK, and GIMP, allow context-dependent attackers to execute arbitrary code via a crafted image file that triggers a heap-based buffer overflow. NOTE: some of these details are obtained from third party information.

Record
EUVD-2009-0723
Updated
2026-11-03
GitHub AdvisoriesGHSA-98mq-jm9g-w68j No score

Multiple integer overflows in LittleCMS (aka lcms or liblcms) before 1.18beta2, as used in...

Multiple integer overflows in LittleCMS (aka lcms or liblcms) before 1.18beta2, as used in Firefox 3.1beta, OpenJDK, and GIMP, allow context-dependent attackers to execute arbitrary code via a crafted image file that triggers a heap-based buffer overflow. NOTE: some of these details are obtained from third party information.

Record
GHSA-98mq-jm9g-w68j
Weakness
CWE-190
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
lcms
Debian:4.0
before 1.15-1.1+etch2, plus listed versions
1.15-11.15-1.1+etch1
1.15-1.1+etch2
lcms
Debian:5.0
before 1.17.dfsg-1+lenny1, plus listed versions
1.17.dfsg-1
1.17.dfsg-1+lenny1
openjdk-6
Debian:5.0
before 6b11-9.1+lenny2, plus listed versions
6b11-9.1
6b11-9.1+lenny2
lcms
Red Hat:enterprise_linux:5::client_workstation
before 0:1.18-0.1.beta1.el5_3.2
0:1.18-0.1.beta1.el5_3.2
lcms-debuginfo
Red Hat:enterprise_linux:5::client_workstation
before 0:1.18-0.1.beta1.el5_3.2
0:1.18-0.1.beta1.el5_3.2
lcms-devel
Red Hat:enterprise_linux:5::client_workstation
before 0:1.18-0.1.beta1.el5_3.2
0:1.18-0.1.beta1.el5_3.2
lcms
Red Hat:enterprise_linux:5::client
before 0:1.18-0.1.beta1.el5_3.2
0:1.18-0.1.beta1.el5_3.2
lcms-debuginfo
Red Hat:enterprise_linux:5::client
before 0:1.18-0.1.beta1.el5_3.2
0:1.18-0.1.beta1.el5_3.2
python-lcms
Red Hat:enterprise_linux:5::client
before 0:1.18-0.1.beta1.el5_3.2
0:1.18-0.1.beta1.el5_3.2
lcms
Red Hat:enterprise_linux:5::server
before 0:1.18-0.1.beta1.el5_3.2
0:1.18-0.1.beta1.el5_3.2
Show 15 moreShow less
Affected packages
PackageAffectedFixed
lcms-debuginfo
Red Hat:enterprise_linux:5::server
before 0:1.18-0.1.beta1.el5_3.2
0:1.18-0.1.beta1.el5_3.2
lcms-devel
Red Hat:enterprise_linux:5::server
before 0:1.18-0.1.beta1.el5_3.2
0:1.18-0.1.beta1.el5_3.2
python-lcms
Red Hat:enterprise_linux:5::server
before 0:1.18-0.1.beta1.el5_3.2
0:1.18-0.1.beta1.el5_3.2
java-1.6.0-openjdk
Red Hat:enterprise_linux:5::client
before 1:1.6.0.0-0.30.b09.el5
1:1.6.0.0-0.30.b09.el5
java-1.6.0-openjdk-debuginfo
Red Hat:enterprise_linux:5::client
before 1:1.6.0.0-0.30.b09.el5
1:1.6.0.0-0.30.b09.el5
java-1.6.0-openjdk-demo
Red Hat:enterprise_linux:5::client
before 1:1.6.0.0-0.30.b09.el5
1:1.6.0.0-0.30.b09.el5
java-1.6.0-openjdk-devel
Red Hat:enterprise_linux:5::client
before 1:1.6.0.0-0.30.b09.el5
1:1.6.0.0-0.30.b09.el5
java-1.6.0-openjdk-javadoc
Red Hat:enterprise_linux:5::client
before 1:1.6.0.0-0.30.b09.el5
1:1.6.0.0-0.30.b09.el5
java-1.6.0-openjdk-src
Red Hat:enterprise_linux:5::client
before 1:1.6.0.0-0.30.b09.el5
1:1.6.0.0-0.30.b09.el5
java-1.6.0-openjdk
Red Hat:enterprise_linux:5::server
before 1:1.6.0.0-0.30.b09.el5
1:1.6.0.0-0.30.b09.el5
java-1.6.0-openjdk-debuginfo
Red Hat:enterprise_linux:5::server
before 1:1.6.0.0-0.30.b09.el5
1:1.6.0.0-0.30.b09.el5
java-1.6.0-openjdk-demo
Red Hat:enterprise_linux:5::server
before 1:1.6.0.0-0.30.b09.el5
1:1.6.0.0-0.30.b09.el5
java-1.6.0-openjdk-devel
Red Hat:enterprise_linux:5::server
before 1:1.6.0.0-0.30.b09.el5
1:1.6.0.0-0.30.b09.el5
java-1.6.0-openjdk-javadoc
Red Hat:enterprise_linux:5::server
before 1:1.6.0.0-0.30.b09.el5
1:1.6.0.0-0.30.b09.el5
java-1.6.0-openjdk-src
Red Hat:enterprise_linux:5::server
before 1:1.6.0.0-0.30.b09.el5
1:1.6.0.0-0.30.b09.el5

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-0723 is a high vulnerability (CVSS 9.3) in Gimp, published March 20, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.03%, the 92nd percentile. Fixed in lcms 1.15-1.1+etch2.

References

Show 93 moreShow less
MoveEnter Open