Every CVE Search/ Get API key

CVE-2009-1150

Multiple cross-site scripting (XSS) vulnerabilities in the export page (display_export.lib.php)...

4.3 MediumFix available

Multiple cross-site scripting (XSS) vulnerabilities in the export page (display_export.lib.php) in phpMyAdmin 2.11.x before 2.11.9.5 and 3.x before 3.1.3.1 allow remote attackers to inject arbitrary web script or HTML via the pma_db_filename_template cookie.

Exploit likelihood

1.60%Down 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Multiple cross-site scripting (XSS) vulnerabilities in the export page (display_export.lib.php) in phpMyAdmin 2.11.x before 2.11.9.5 and 3.x before 3.1.3.1 allow remote attackers to inject arbitrary web script or HTML via the pma_db_filename_template cookie.

Record
CVE-2009-1150
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Multiple cross-site scripting (XSS) vulnerabilities in the export page (display_export.lib.php) in phpMyAdmin 2.11.x before 2.11.9.5 and 3.x before 3.1.3.1 allow remote attackers to inject arbitrary web script or HTML via the pma_db_filename_template cookie.

Record
CVE-2009-1150
Updated
2026-11-02
EUVDEUVD-2009-1150 No score

Multiple cross-site scripting (XSS) vulnerabilities in the export page (display_export.lib.php) in phpMyAdmin 2.11.x before 2.11.9.5 and 3.x before 3.1.3.1 allow remote attackers to inject arbitrary web script or HTML via the pma_db_filename_template cookie.

Record
EUVD-2009-1150
Updated
2026-11-03
GitHub AdvisoriesGHSA-pgqx-hcp9-24pq No score

Multiple cross-site scripting (XSS) vulnerabilities in the export page (display_export.lib.php)...

Multiple cross-site scripting (XSS) vulnerabilities in the export page (display_export.lib.php) in phpMyAdmin 2.11.x before 2.11.9.5 and 3.x before 3.1.3.1 allow remote attackers to inject arbitrary web script or HTML via the pma_db_filename_template cookie.

Record
GHSA-pgqx-hcp9-24pq
Weakness
CWE-79
Updated
2026-11-02
OSV No score

Multiple cross-site scripting (XSS) vulnerabilities in the export page (display_export.lib.php) in phpMyAdmin 2.11.x before 2.11.9.5 and 3.x before 3.1.3.1 allow remote attackers to inject arbitrary web script or HTML via the pma_db_filename_template cookie.

Record
CVE-2009-1150
Updated
2026-11-02
OSVDEBIAN-CVE-2009-1150 No score

Multiple cross-site scripting (XSS) vulnerabilities in the export page (display_export.lib.php) in phpMyAdmin 2.11.x before 2.11.9.5 and 3.x before 3.1.3.1 allow remote attackers to inject arbitrary web script or HTML via the pma_db_filename_template cookie.

Record
DEBIAN-CVE-2009-1150
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
phpmyadmin
Debian:12
before 4:3.1.3.1-1
4:3.1.3.1-1
phpmyadmin
Debian:13
before 4:3.1.3.1-1
4:3.1.3.1-1
phpmyadmin
Debian:14
before 4:3.1.3.1-1
4:3.1.3.1-1
phpmyadmin
Debian:4.0
From an advisory covering 2 CVEs
before 4:2.9.1.1-11, plus listed versions
4:2.9.1.1-104:2.9.1.1-34:2.9.1.1-44:2.9.1.1-54:2.9.1.1-64:2.9.1.1-74:2.9.1.1-84:2.9.1.1-9
4:2.9.1.1-11
phpmyadmin
Debian:5.0
From an advisory covering 2 CVEs
before 4:2.11.8.1-5+lenny1, plus listed versions
4:2.11.8.1-5
4:2.11.8.1-5+lenny1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-1150 is a medium vulnerability (CVSS 4.3) in Phpmyadmin, published March 26, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.60%, the 75th percentile. Fixed in phpmyadmin 4:3.1.3.1-1.

References

Show 8 moreShow less
MoveEnter Open