Every CVE Search/ Get API key

CVE-2009-1384

pam_krb5 2.2.14 through 2.3.4, as used in Red Hat Enterprise Linux (RHEL) 5, generates different...

5.0 MediumFix available

pam_krb5 2.2.14 through 2.3.4, as used in Red Hat Enterprise Linux (RHEL) 5, generates different password prompts depending on whether the user account exists, which allows remote attackers to enumerate valid usernames.

Exploit likelihood

2.89%Up 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

pam_krb5 2.2.14 through 2.3.4, as used in Red Hat Enterprise Linux (RHEL) 5, generates different password prompts depending on whether the user account exists, which allows remote attackers to enumerate valid usernames.

Record
CVE-2009-1384
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-287
Updated
2026-11-02
CVE List No score

pam_krb5 2.2.14 through 2.3.4, as used in Red Hat Enterprise Linux (RHEL) 5, generates different password prompts depending on whether the user account exists, which allows remote attackers to enumerate valid usernames.

Record
CVE-2009-1384
Updated
2026-11-02
EUVDEUVD-2009-1382 No score

pam_krb5 2.2.14 through 2.3.4, as used in Red Hat Enterprise Linux (RHEL) 5, generates different password prompts depending on whether the user account exists, which allows remote attackers to enumerate valid usernames.

Record
EUVD-2009-1382
Updated
2026-11-03
GitHub AdvisoriesGHSA-7qjh-v92x-xj4g No score

pam_krb5 2.2.14 through 2.3.4, as used in Red Hat Enterprise Linux (RHEL) 5, generates different...

pam_krb5 2.2.14 through 2.3.4, as used in Red Hat Enterprise Linux (RHEL) 5, generates different password prompts depending on whether the user account exists, which allows remote attackers to enumerate valid usernames.

Record
GHSA-7qjh-v92x-xj4g
Weakness
CWE-287
Updated
2026-11-02
OSVopenSUSE-SU-2024:10521-1 No score

pam_krb5-2.4.4-6.7 on GA media

These are all security issues fixed in the pam_krb5-2.4.4-6.7 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10521-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pam_krb5
Red Hat:enterprise_linux:5::client
before 0:2.2.14-15
0:2.2.14-15
pam_krb5-debuginfo
Red Hat:enterprise_linux:5::client
before 0:2.2.14-15
0:2.2.14-15
pam_krb5
Red Hat:enterprise_linux:5::server
before 0:2.2.14-15
0:2.2.14-15
pam_krb5-debuginfo
Red Hat:enterprise_linux:5::server
before 0:2.2.14-15
0:2.2.14-15

History

History
RecordedChangedSources
facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-1384 is a medium vulnerability (CVSS 5.0) in Eyrie Pam-krb5, published May 28, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.89%, the 86th percentile. Fixed in pam_krb5 0:2.2.14-15.

References

Show 19 moreShow less
MoveEnter Open