Every CVE Search/ Get API key

CVE-2009-1570

Integer overflow in the ReadImage function in plug-ins/file-bmp/bmp-read.c in GIMP 2.6.7 might...

9.3 HighFix available

Integer overflow in the ReadImage function in plug-ins/file-bmp/bmp-read.c in GIMP 2.6.7 might allow remote attackers to execute arbitrary code via a BMP file with crafted width and height values that trigger a heap-based buffer overflow.

Exploit likelihood

8.04%Down 1.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.3

Integer overflow in the ReadImage function in plug-ins/file-bmp/bmp-read.c in GIMP 2.6.7 might allow remote attackers to execute arbitrary code via a BMP file with crafted width and height values that trigger a heap-based buffer overflow.

Record
CVE-2009-1570
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-190
Updated
2026-11-02
CVE List No score

Integer overflow in the ReadImage function in plug-ins/file-bmp/bmp-read.c in GIMP 2.6.7 might allow remote attackers to execute arbitrary code via a BMP file with crafted width and height values that trigger a heap-based buffer overflow.

Record
CVE-2009-1570
Updated
2026-11-02
EUVDEUVD-2009-1566 No score

Integer overflow in the ReadImage function in plug-ins/file-bmp/bmp-read.c in GIMP 2.6.7 might allow remote attackers to execute arbitrary code via a BMP file with crafted width and height values that trigger a heap-based buffer overflow.

Record
EUVD-2009-1566
Updated
2026-11-03
GitHub AdvisoriesGHSA-433f-rgxw-j2rj No score

Integer overflow in the ReadImage function in plug-ins/file-bmp/bmp-read.c in GIMP 2.6.7 might...

Integer overflow in the ReadImage function in plug-ins/file-bmp/bmp-read.c in GIMP 2.6.7 might allow remote attackers to execute arbitrary code via a BMP file with crafted width and height values that trigger a heap-based buffer overflow.

Record
GHSA-433f-rgxw-j2rj
Weakness
CWE-190
Updated
2026-11-02
OSV No score

Integer overflow in the ReadImage function in plug-ins/file-bmp/bmp-read.c in GIMP 2.6.7 might allow remote attackers to execute arbitrary code via a BMP file with crafted width and height values that trigger a heap-based buffer overflow.

Record
CVE-2009-1570
Updated
2026-11-02
OSVDEBIAN-CVE-2009-1570 No score

Integer overflow in the ReadImage function in plug-ins/file-bmp/bmp-read.c in GIMP 2.6.7 might allow remote attackers to execute arbitrary code via a BMP file with crafted width and height values that trigger a heap-based buffer overflow.

Record
DEBIAN-CVE-2009-1570
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gimp
Debian:12
before 2.6.7-1.1
2.6.7-1.1
gimp
Debian:13
before 2.6.7-1.1
2.6.7-1.1
gimp
Debian:14
before 2.6.7-1.1
2.6.7-1.1
gimp
Red Hat:enterprise_linux:4::as
before 1:2.0.5-7.0.7.el4.1
1:2.0.5-7.0.7.el4.1
gimp-debuginfo
Red Hat:enterprise_linux:4::as
before 1:2.0.5-7.0.7.el4.1
1:2.0.5-7.0.7.el4.1
gimp-devel
Red Hat:enterprise_linux:4::as
before 1:2.0.5-7.0.7.el4.1
1:2.0.5-7.0.7.el4.1
gimp
Red Hat:enterprise_linux:4::desktop
before 1:2.0.5-7.0.7.el4.1
1:2.0.5-7.0.7.el4.1
gimp-debuginfo
Red Hat:enterprise_linux:4::desktop
before 1:2.0.5-7.0.7.el4.1
1:2.0.5-7.0.7.el4.1
gimp-devel
Red Hat:enterprise_linux:4::desktop
before 1:2.0.5-7.0.7.el4.1
1:2.0.5-7.0.7.el4.1
gimp
Red Hat:enterprise_linux:4::es
before 1:2.0.5-7.0.7.el4.1
1:2.0.5-7.0.7.el4.1
Show 9 moreShow less
Affected packages
PackageAffectedFixed
gimp-debuginfo
Red Hat:enterprise_linux:4::es
before 1:2.0.5-7.0.7.el4.1
1:2.0.5-7.0.7.el4.1
gimp-devel
Red Hat:enterprise_linux:4::es
before 1:2.0.5-7.0.7.el4.1
1:2.0.5-7.0.7.el4.1
gimp
Red Hat:enterprise_linux:4::ws
before 1:2.0.5-7.0.7.el4.1
1:2.0.5-7.0.7.el4.1
gimp-debuginfo
Red Hat:enterprise_linux:4::ws
before 1:2.0.5-7.0.7.el4.1
1:2.0.5-7.0.7.el4.1
gimp-devel
Red Hat:enterprise_linux:4::ws
before 1:2.0.5-7.0.7.el4.1
1:2.0.5-7.0.7.el4.1
gimp
Red Hat:enterprise_linux:5::server
before 2:2.2.13-2.0.7.el5_6.2
2:2.2.13-2.0.7.el5_6.2
gimp-debuginfo
Red Hat:enterprise_linux:5::server
before 2:2.2.13-2.0.7.el5_6.2
2:2.2.13-2.0.7.el5_6.2
gimp-devel
Red Hat:enterprise_linux:5::server
before 2:2.2.13-2.0.7.el5_6.2
2:2.2.13-2.0.7.el5_6.2
gimp-libs
Red Hat:enterprise_linux:5::server
before 2:2.2.13-2.0.7.el5_6.2
2:2.2.13-2.0.7.el5_6.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-1570 is a high vulnerability (CVSS 9.3) in Gimp, published November 13, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 8.04%, the 94th percentile. Fixed in gimp 2.6.7-1.1.

References

Show 42 moreShow less
MoveEnter Open