Every CVE Search/ Get API key

CVE-2009-2281

Multiple heap-based buffer underflows in the readPostBody function in cgiutil.c in mapserv in...

10.0 HighFix available

Multiple heap-based buffer underflows in the readPostBody function in cgiutil.c in mapserv in MapServer 4.x through 4.10.4 and 5.x before 5.4.2 allow remote attackers to execute arbitrary code via (1) a crafted Content-Length HTTP header or (2) a large HTTP request, related to an integer overflow that triggers a heap-based buffer overflow. NOTE: this issue reportedly exists because of an incomplete fix for CVE-2009-0840.

Exploit likelihood

5.95%Down 1.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 10.0

Multiple heap-based buffer underflows in the readPostBody function in cgiutil.c in mapserv in MapServer 4.x through 4.10.4 and 5.x before 5.4.2 allow remote attackers to execute arbitrary code via (1) a crafted Content-Length HTTP header or (2) a large HTTP request, related to an integer overflow that triggers a heap-based buffer overflow. NOTE: this issue reportedly exists because of an incomplete fix for CVE-2009-0840.

Record
CVE-2009-2281
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Multiple heap-based buffer underflows in the readPostBody function in cgiutil.c in mapserv in MapServer 4.x through 4.10.4 and 5.x before 5.4.2 allow remote attackers to execute arbitrary code via (1) a crafted Content-Length HTTP header or (2) a large HTTP request, related to an integer overflow that triggers a heap-based buffer overflow. NOTE: this issue reportedly exists because of an incomplete fix for CVE-2009-0840.

Record
CVE-2009-2281
Updated
2026-11-02
EUVDEUVD-2009-2277 No score

Multiple heap-based buffer underflows in the readPostBody function in cgiutil.c in mapserv in MapServer 4.x through 4.10.4 and 5.x before 5.4.2 allow remote attackers to execute arbitrary code via (1) a crafted Content-Length HTTP header or (2) a large HTTP request, related to an integer overflow that triggers a heap-based buffer overflow. NOTE: this issue reportedly exists because of an incomplete fix for CVE-2009-0840.

Record
EUVD-2009-2277
Updated
2026-11-03
GitHub AdvisoriesGHSA-6726-5cj2-9h6f No score

Multiple heap-based buffer underflows in the readPostBody function in cgiutil.c in mapserv in...

Multiple heap-based buffer underflows in the readPostBody function in cgiutil.c in mapserv in MapServer 4.x through 4.10.4 and 5.x before 5.4.2 allow remote attackers to execute arbitrary code via (1) a crafted Content-Length HTTP header or (2) a large HTTP request, related to an integer overflow that triggers a heap-based buffer overflow. NOTE: this issue reportedly exists because of an incomplete fix for CVE-2009-0840.

Record
GHSA-6726-5cj2-9h6f
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Multiple heap-based buffer underflows in the readPostBody function in cgiutil.c in mapserv in MapServer 4.x through 4.10.4 and 5.x before 5.4.2 allow remote attackers to execute arbitrary code via (1) a crafted Content-Length HTTP header or (2) a large HTTP request, related to an integer overflow that triggers a heap-based buffer overflow. NOTE: this issue reportedly exists because of an incomplete fix for CVE-2009-0840.

Record
CVE-2009-2281
Updated
2026-11-02
OSVDEBIAN-CVE-2009-2281 No score

Multiple heap-based buffer underflows in the readPostBody function in cgiutil.c in mapserv in MapServer 4.x through 4.10.4 and 5.x before 5.4.2 allow remote attackers to execute arbitrary code via (1) a crafted Content-Length HTTP header or (2) a large HTTP request, related to an integer overflow that triggers a heap-based buffer overflow. NOTE: this issue reportedly exists because of an incomplete fix for CVE-2009-0840.

Record
DEBIAN-CVE-2009-2281
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mapserver
Debian:12
before 5.4.2-1
5.4.2-1
mapserver
Debian:13
before 5.4.2-1
5.4.2-1
mapserver
Debian:14
before 5.4.2-1
5.4.2-1
mapserver
Debian:4.0
From an advisory covering 7 CVEs
before 4.10.0-5.1+etch4, plus listed versions
4.10.0-5+etch14.10.0-5.1+etch2
4.10.0-5.1+etch4
mapserver
Debian:5.0
From an advisory covering 7 CVEs
before 5.0.3-3+lenny4, plus listed versions
5.0.3-3
5.0.3-3+lenny4

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-2281 is a high vulnerability (CVSS 10.0) in Osgeo Mapserver, published October 22, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.95%, the 93rd percentile. Fixed in mapserver 5.4.2-1.

References

Show 4 moreShow less
MoveEnter Open