Every CVE Search/ Get API key

CVE-2009-2284

Cross-site scripting (XSS) vulnerability in phpMyAdmin before 3.2.0.1 allows remote attackers to...

4.3 MediumFix available

Cross-site scripting (XSS) vulnerability in phpMyAdmin before 3.2.0.1 allows remote attackers to inject arbitrary web script or HTML via a crafted SQL bookmark.

Exploit likelihood

1.98%Up 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in phpMyAdmin before 3.2.0.1 allows remote attackers to inject arbitrary web script or HTML via a crafted SQL bookmark.

Record
CVE-2009-2284
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in phpMyAdmin before 3.2.0.1 allows remote attackers to inject arbitrary web script or HTML via a crafted SQL bookmark.

Record
CVE-2009-2284
Updated
2026-11-02
EUVDEUVD-2009-2280 No score

Cross-site scripting (XSS) vulnerability in phpMyAdmin before 3.2.0.1 allows remote attackers to inject arbitrary web script or HTML via a crafted SQL bookmark.

Record
EUVD-2009-2280
Updated
2026-11-03
GitHub AdvisoriesGHSA-fm9c-6g88-w6vp No score

Cross-site scripting (XSS) vulnerability in phpMyAdmin before 3.2.0.1 allows remote attackers to...

Cross-site scripting (XSS) vulnerability in phpMyAdmin before 3.2.0.1 allows remote attackers to inject arbitrary web script or HTML via a crafted SQL bookmark.

Record
GHSA-fm9c-6g88-w6vp
Weakness
CWE-79
Updated
2026-11-02
OSV No score

Cross-site scripting (XSS) vulnerability in phpMyAdmin before 3.2.0.1 allows remote attackers to inject arbitrary web script or HTML via a crafted SQL bookmark.

Record
CVE-2009-2284
Updated
2026-11-02
OSVDEBIAN-CVE-2009-2284 No score

Cross-site scripting (XSS) vulnerability in phpMyAdmin before 3.2.0.1 allows remote attackers to inject arbitrary web script or HTML via a crafted SQL bookmark.

Record
DEBIAN-CVE-2009-2284
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
phpmyadmin
Debian:12
before 4:3.2.0.1-1
4:3.2.0.1-1
phpmyadmin
Debian:13
before 4:3.2.0.1-1
4:3.2.0.1-1
phpmyadmin
Debian:14
before 4:3.2.0.1-1
4:3.2.0.1-1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-2284 is a medium vulnerability (CVSS 4.3) in Phpmyadmin, published July 1, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.98%, the 80th percentile. Fixed in phpmyadmin 4:3.2.0.1-1.

References

Show 4 moreShow less
MoveEnter Open