CVE-2009-4102
Sage 1.4.3 and earlier extension for Firefox performs certain operations with chrome privileges,...
Sage 1.4.3 and earlier extension for Firefox performs certain operations with chrome privileges, which allows remote attackers to execute arbitrary commands and perform cross-domain scripting attacks via the description tag of an RSS feed.
Exploit likelihood
What each source reports
NVD Score used
9.3
Sage 1.4.3 and earlier extension for Firefox performs certain operations with chrome privileges, which allows remote attackers to execute arbitrary commands and perform cross-domain scripting attacks via the description tag of an RSS feed.
- Record
CVE-2009-4102- CVSS 2.0
- 9.3 High
AV:N/AC:M/Au:N/C:C/I:C/A:C - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
Sage 1.4.3 and earlier extension for Firefox performs certain operations with chrome privileges, which allows remote attackers to execute arbitrary commands and perform cross-domain scripting attacks via the description tag of an RSS feed.
- Record
CVE-2009-4102- Updated
- 2026-11-02
EUVDEUVD-2009-4073 No score
Sage 1.4.3 and earlier extension for Firefox performs certain operations with chrome privileges, which allows remote attackers to execute arbitrary commands and perform cross-domain scripting attacks via the description tag of an RSS feed.
- Record
EUVD-2009-4073- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-g29q-9g3g-6fjr No score
Sage 1.4.3 and earlier extension for Firefox performs certain operations with chrome privileges,...
Sage 1.4.3 and earlier extension for Firefox performs certain operations with chrome privileges, which allows remote attackers to execute arbitrary commands and perform cross-domain scripting attacks via the description tag of an RSS feed.
- Record
GHSA-g29q-9g3g-6fjr- Weakness
- CWE-20
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
firefox-sageDebian:4.0 |
before 1.3.6-4etch1, plus listed versions 1.3.6-4 |
1.3.6-4etch1 |
firefox-sageDebian:5.0 |
before 1.4.2-0.1+lenny1, plus listed versions 1.4.2-0.1 |
1.4.2-0.1+lenny1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2009-4102 is a high vulnerability (CVSS 9.3) in Mozilla Firefox, published November 28, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.39%, the 88th percentile. Fixed in firefox-sage 1.3.6-4etch1.