Every CVE Search/ Get API key

CVE-2009-4131

The EXT4_IOC_MOVE_EXT (aka move extents) ioctl implementation in the ext4 filesystem in the Linux...

7.2 HighPublic exploit

The EXT4_IOC_MOVE_EXT (aka move extents) ioctl implementation in the ext4 filesystem in the Linux kernel before 2.6.32-git6 allows local users to overwrite arbitrary files via a crafted request, related to insufficient checks for file permissions.

Exploit likelihood

0.79%Down 2.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.2

The EXT4_IOC_MOVE_EXT (aka move extents) ioctl implementation in the ext4 filesystem in the Linux kernel before 2.6.32-git6 allows local users to overwrite arbitrary files via a crafted request, related to insufficient checks for file permissions.

Record
CVE-2009-4131
CVSS 2.0
7.2 HighAV:L/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

The EXT4_IOC_MOVE_EXT (aka move extents) ioctl implementation in the ext4 filesystem in the Linux kernel before 2.6.32-git6 allows local users to overwrite arbitrary files via a crafted request, related to insufficient checks for file permissions.

Record
CVE-2009-4131
Updated
2026-11-02
EUVDEUVD-2009-4101 No score

The EXT4_IOC_MOVE_EXT (aka move extents) ioctl implementation in the ext4 filesystem in the Linux kernel before 2.6.32-git6 allows local users to overwrite arbitrary files via a crafted request, related to insufficient checks for file permissions.

Record
EUVD-2009-4101
Updated
2026-11-03
GitHub AdvisoriesGHSA-w5q9-4w6f-xc45 No score

The EXT4_IOC_MOVE_EXT (aka move extents) ioctl implementation in the ext4 filesystem in the Linux...

The EXT4_IOC_MOVE_EXT (aka move extents) ioctl implementation in the ext4 filesystem in the Linux kernel before 2.6.32-git6 allows local users to overwrite arbitrary files via a crafted request, related to insufficient checks for file permissions.

Record
GHSA-w5q9-4w6f-xc45
Updated
2026-11-02
OSVopenSUSE-SU-2024:10128-1 No score

kernel-debug-4.8.13-1.1 on GA media

These are all security issues fixed in the kernel-debug-4.8.13-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10128-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
kernel-source
openSUSE:Tumbleweed
From an advisory covering 82 CVEs
before 4.8.13-1.1
4.8.13-1.1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBLinux Kernel 2.6.x - Ext4 'move extents' ioctl Privilege Escalation2009-11-09

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-4131 is a high vulnerability (CVSS 7.2) in Linux Kernel, published December 13, 2009. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 0.79%, the 56th percentile. No source names a fixed version.

References

Show 94 moreShow less
MoveEnter Open