Every CVE Search/ Get API key

CVE-2009-4638

Integer overflow in FFmpeg 0.5 allows remote attackers to cause a denial of service (crash) and...

4.3 MediumFix available

Integer overflow in FFmpeg 0.5 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unknown vectors.

Exploit likelihood

3.90%Down 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Integer overflow in FFmpeg 0.5 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unknown vectors.

Record
CVE-2009-4638
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-189
Updated
2026-11-02
CVE List No score

Integer overflow in FFmpeg 0.5 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unknown vectors.

Record
CVE-2009-4638
Updated
2026-11-02
EUVDEUVD-2009-4603 No score

Integer overflow in FFmpeg 0.5 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unknown vectors.

Record
EUVD-2009-4603
Updated
2026-11-03
GitHub AdvisoriesGHSA-vjfc-38px-5h83 No score

Integer overflow in FFmpeg 0.5 allows remote attackers to cause a denial of service (crash) and...

Integer overflow in FFmpeg 0.5 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unknown vectors.

Record
GHSA-vjfc-38px-5h83
Updated
2026-11-02
OSV No score

Integer overflow in FFmpeg 0.5 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unknown vectors.

Record
CVE-2009-4638
Updated
2026-11-02
OSVDEBIAN-CVE-2009-4638 No score

Integer overflow in FFmpeg 0.5 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unknown vectors.

Record
DEBIAN-CVE-2009-4638
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ffmpeg
Debian:12
before 4:0.5+svn20090706-3
4:0.5+svn20090706-3
ffmpeg
Debian:13
before 4:0.5+svn20090706-3
4:0.5+svn20090706-3
ffmpeg
Debian:14
before 4:0.5+svn20090706-3
4:0.5+svn20090706-3
ffmpeg-debian
Debian:5.0
From an advisory covering 9 CVEs
before 0.svn20080206-18+lenny1, plus listed versions
0.svn20080206-160.svn20080206-170.svn20080206-17+lenny10.svn20080206-18
0.svn20080206-18+lenny1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-4638 is a medium vulnerability (CVSS 4.3) in Ffmpeg, published February 10, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.90%, the 90th percentile. Fixed in ffmpeg 4:0.5+svn20090706-3.

References

MoveEnter Open