Every CVE Search/ Get API key

CVE-2009-4640

Array index error in vorbis_dec.c in FFmpeg 0.5 allows remote attackers to cause a denial of...

4.3 MediumFix available

Array index error in vorbis_dec.c in FFmpeg 0.5 allows remote attackers to cause a denial of service and possibly execute arbitrary code via a crafted Vorbis file that triggers an out-of-bounds read.

Exploit likelihood

3.96%Down 2.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Array index error in vorbis_dec.c in FFmpeg 0.5 allows remote attackers to cause a denial of service and possibly execute arbitrary code via a crafted Vorbis file that triggers an out-of-bounds read.

Record
CVE-2009-4640
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-189
Updated
2026-11-02
CVE List No score

Array index error in vorbis_dec.c in FFmpeg 0.5 allows remote attackers to cause a denial of service and possibly execute arbitrary code via a crafted Vorbis file that triggers an out-of-bounds read.

Record
CVE-2009-4640
Updated
2026-11-02
EUVDEUVD-2009-4605 No score

Array index error in vorbis_dec.c in FFmpeg 0.5 allows remote attackers to cause a denial of service and possibly execute arbitrary code via a crafted Vorbis file that triggers an out-of-bounds read.

Record
EUVD-2009-4605
Updated
2026-11-03
GitHub AdvisoriesGHSA-qrm3-2wv2-w4qv No score

Array index error in vorbis_dec.c in FFmpeg 0.5 allows remote attackers to cause a denial of...

Array index error in vorbis_dec.c in FFmpeg 0.5 allows remote attackers to cause a denial of service and possibly execute arbitrary code via a crafted Vorbis file that triggers an out-of-bounds read.

Record
GHSA-qrm3-2wv2-w4qv
Updated
2026-11-02
OSV No score

Array index error in vorbis_dec.c in FFmpeg 0.5 allows remote attackers to cause a denial of service and possibly execute arbitrary code via a crafted Vorbis file that triggers an out-of-bounds read.

Record
CVE-2009-4640
Updated
2026-11-02
OSVDEBIAN-CVE-2009-4640 No score

Array index error in vorbis_dec.c in FFmpeg 0.5 allows remote attackers to cause a denial of service and possibly execute arbitrary code via a crafted Vorbis file that triggers an out-of-bounds read.

Record
DEBIAN-CVE-2009-4640
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ffmpeg
Debian:12
before 4:0.5+svn20090706-3
4:0.5+svn20090706-3
ffmpeg
Debian:13
before 4:0.5+svn20090706-3
4:0.5+svn20090706-3
ffmpeg
Debian:14
before 4:0.5+svn20090706-3
4:0.5+svn20090706-3
ffmpeg-debian
Debian:5.0
From an advisory covering 9 CVEs
before 0.svn20080206-18+lenny1, plus listed versions
0.svn20080206-160.svn20080206-170.svn20080206-17+lenny10.svn20080206-18
0.svn20080206-18+lenny1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-4640 is a medium vulnerability (CVSS 4.3) in Ffmpeg, published February 10, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.96%, the 90th percentile. Fixed in ffmpeg 4:0.5+svn20090706-3.

References

Show 12 moreShow less
MoveEnter Open