Every CVE Search/ Get API key

CVE-2010-1619

Moodle vulnerable to Cross-site Scripting

4.3 MediumFix available

Cross-site scripting (XSS) vulnerability in the fix_non_standard_entities function in the KSES HTML text cleaning library (weblib.php), as used in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8, allows remote attackers to inject arbitrary web script or HTML via crafted HTML entities.

Exploit likelihood

1.67%Up 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in the fix_non_standard_entities function in the KSES HTML text cleaning library (weblib.php), as used in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8, allows remote attackers to inject arbitrary web script or HTML via crafted HTML entities.

Record
CVE-2010-1619
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in the fix_non_standard_entities function in the KSES HTML text cleaning library (weblib.php), as used in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8, allows remote attackers to inject arbitrary web script or HTML via crafted HTML entities.

Record
CVE-2010-1619
Updated
2026-11-02
EUVDEUVD-2010-1643 No score

Cross-site scripting (XSS) vulnerability in the fix_non_standard_entities function in the KSES HTML text cleaning library (weblib.php), as used in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8, allows remote attackers to inject arbitrary web script or HTML via crafted HTML entities.

Record
EUVD-2010-1643
Updated
2026-11-03
GitHub AdvisoriesGHSA-hhxf-w8hj-43w6 1.3

Moodle vulnerable to Cross-site Scripting

Cross-site scripting (XSS) vulnerability in the fix_non_standard_entities function in the KSES HTML text cleaning library (weblib.php), as used in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8, allows remote attackers to inject arbitrary web script or HTML via crafted HTML entities.

Record
GHSA-hhxf-w8hj-43w6
CVSS 4.0
1.3 LowCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-hhxf-w8hj-43w6 1.3

Moodle vulnerable to Cross-site Scripting

Cross-site scripting (XSS) vulnerability in the fix_non_standard_entities function in the KSES HTML text cleaning library (weblib.php), as used in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8, allows remote attackers to inject arbitrary web script or HTML via crafted HTML entities.

Record
GHSA-hhxf-w8hj-43w6
CVSS 4.0
1.3 LowCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
1.8.0 up to 1.8.12
1.8.12
moodle/moodle
Packagist
1.9.0 up to 1.9.8
1.9.8
moodle
Debian:5.0
From an advisory covering 13 CVEs
before 1.8.13-1, plus listed versions
1.8.2.dfsg-31.8.2.dfsg-3+lenny11.8.2.dfsg-3+lenny21.8.2.dfsg-3+lenny31.8.2.dfsg-4
Show 4 moreShow less
1.8.2.dfsg-51.8.2.dfsg-5.11.8.2.dfsg-61.8.2.dfsg-6.1
1.8.13-1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2010-1619 is a medium vulnerability (CVSS 4.3) in Moodle, published April 29, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.67%, the 76th percentile. Fixed in moodle/moodle 1.8.12.

References

MoveEnter Open