Every CVE Search/ Get API key

CVE-2010-2540

mapserv.c in mapserv in MapServer before 4.10.6 and 5.x before 5.6.4 does not properly restrict...

10.0 HighFix available

mapserv.c in mapserv in MapServer before 4.10.6 and 5.x before 5.6.4 does not properly restrict the use of CGI command-line arguments that were intended for debugging, which allows remote attackers to have an unspecified impact via crafted arguments.

Exploit likelihood

3.83%Up 2.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 10.0

mapserv.c in mapserv in MapServer before 4.10.6 and 5.x before 5.6.4 does not properly restrict the use of CGI command-line arguments that were intended for debugging, which allows remote attackers to have an unspecified impact via crafted arguments.

Record
CVE-2010-2540
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

mapserv.c in mapserv in MapServer before 4.10.6 and 5.x before 5.6.4 does not properly restrict the use of CGI command-line arguments that were intended for debugging, which allows remote attackers to have an unspecified impact via crafted arguments.

Record
CVE-2010-2540
Updated
2026-11-02
EUVDEUVD-2010-2544 No score

mapserv.c in mapserv in MapServer before 4.10.6 and 5.x before 5.6.4 does not properly restrict the use of CGI command-line arguments that were intended for debugging, which allows remote attackers to have an unspecified impact via crafted arguments.

Record
EUVD-2010-2544
Updated
2026-11-03
GitHub AdvisoriesGHSA-rvf8-gfc4-3j6f No score

mapserv.c in mapserv in MapServer before 4.10.6 and 5.x before 5.6.4 does not properly restrict...

mapserv.c in mapserv in MapServer before 4.10.6 and 5.x before 5.6.4 does not properly restrict the use of CGI command-line arguments that were intended for debugging, which allows remote attackers to have an unspecified impact via crafted arguments.

Record
GHSA-rvf8-gfc4-3j6f
Updated
2026-11-02
OSV No score

mapserv.c in mapserv in MapServer before 4.10.6 and 5.x before 5.6.4 does not properly restrict the use of CGI command-line arguments that were intended for debugging, which allows remote attackers to have an unspecified impact via crafted arguments.

Record
CVE-2010-2540
Updated
2026-11-02
OSVDEBIAN-CVE-2010-2540 No score

mapserv.c in mapserv in MapServer before 4.10.6 and 5.x before 5.6.4 does not properly restrict the use of CGI command-line arguments that were intended for debugging, which allows remote attackers to have an unspecified impact via crafted arguments.

Record
DEBIAN-CVE-2010-2540
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mapserver
Debian:12
before 5.6.4-1
5.6.4-1
mapserver
Debian:13
before 5.6.4-1
5.6.4-1
mapserver
Debian:14
before 5.6.4-1
5.6.4-1
mapserver
Debian:5.0
From an advisory covering 2 CVEs
before 5.0.3-3+lenny5, plus listed versions
5.0.3-35.0.3-3+lenny4
5.0.3-3+lenny5

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2010-2540 is a high vulnerability (CVSS 10.0) in Osgeo Mapserver, published July 31, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.83%, the 90th percentile. Fixed in mapserver 5.6.4-1.

References

MoveEnter Open