Every CVE Search/ Get API key

CVE-2010-2713

The vte_sequence_handler_window_manipulation function in vteseq.c in libvte (aka libvte9) in VTE...

6.8 MediumFix available

The vte_sequence_handler_window_manipulation function in vteseq.c in libvte (aka libvte9) in VTE 0.25.1 and earlier, as used in gnome-terminal, does not properly handle escape sequences, which allows remote attackers to execute arbitrary commands or obtain potentially sensitive information via a (1) window title or (2) icon title sequence. NOTE: this issue exists because of a CVE-2003-0070 regression.

Exploit likelihood

3.34%Up 2.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

The vte_sequence_handler_window_manipulation function in vteseq.c in libvte (aka libvte9) in VTE 0.25.1 and earlier, as used in gnome-terminal, does not properly handle escape sequences, which allows remote attackers to execute arbitrary commands or obtain potentially sensitive information via a (1) window title or (2) icon title sequence. NOTE: this issue exists because of a CVE-2003-0070 regression.

Record
CVE-2010-2713
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

The vte_sequence_handler_window_manipulation function in vteseq.c in libvte (aka libvte9) in VTE 0.25.1 and earlier, as used in gnome-terminal, does not properly handle escape sequences, which allows remote attackers to execute arbitrary commands or obtain potentially sensitive information via a (1) window title or (2) icon title sequence. NOTE: this issue exists because of a CVE-2003-0070 regression.

Record
CVE-2010-2713
Updated
2026-11-02
EUVDEUVD-2010-2717 No score

The vte_sequence_handler_window_manipulation function in vteseq.c in libvte (aka libvte9) in VTE 0.25.1 and earlier, as used in gnome-terminal, does not properly handle escape sequences, which allows remote attackers to execute arbitrary commands or obtain potentially sensitive information via a (1) window title or (2) icon title sequence. NOTE: this issue exists because of a CVE-2003-0070 regression.

Record
EUVD-2010-2717
Updated
2026-11-03
GitHub AdvisoriesGHSA-h3vh-54q4-255x No score

The vte_sequence_handler_window_manipulation function in vteseq.c in libvte (aka libvte9) in VTE...

The vte_sequence_handler_window_manipulation function in vteseq.c in libvte (aka libvte9) in VTE 0.25.1 and earlier, as used in gnome-terminal, does not properly handle escape sequences, which allows remote attackers to execute arbitrary commands or obtain potentially sensitive information via a (1) window title or (2) icon title sequence. NOTE: this issue exists because of a CVE-2003-0070 regression.

Record
GHSA-h3vh-54q4-255x
Updated
2026-11-02
OSV No score

The vte_sequence_handler_window_manipulation function in vteseq.c in libvte (aka libvte9) in VTE 0.25.1 and earlier, as used in gnome-terminal, does not properly handle escape sequences, which allows remote attackers to execute arbitrary commands or obtain potentially sensitive information via a (1) window title or (2) icon title sequence. NOTE: this issue exists because of a CVE-2003-0070 regression.

Record
CVE-2010-2713
Updated
2026-11-02
OSVDEBIAN-CVE-2010-2713 No score

The vte_sequence_handler_window_manipulation function in vteseq.c in libvte (aka libvte9) in VTE 0.25.1 and earlier, as used in gnome-terminal, does not properly handle escape sequences, which allows remote attackers to execute arbitrary commands or obtain potentially sensitive information via a (1) window title or (2) icon title sequence. NOTE: this issue exists because of a CVE-2003-0070 regression.

Record
DEBIAN-CVE-2010-2713
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
vte
Debian:12
before 1:0.24.3-1
1:0.24.3-1
vte
Debian:13
before 1:0.24.3-1
1:0.24.3-1
vte
Debian:14
before 1:0.24.3-1
1:0.24.3-1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2010-2713 is a medium vulnerability (CVSS 6.8) in Nalin Dahyabhai Vte, published August 5, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.34%, the 88th percentile. Fixed in vte 1:0.24.3-1.

References

Show 4 moreShow less
MoveEnter Open