Every CVE Search/ Get API key

CVE-2010-2884

Adobe Flash Player 10.1.82.76 and earlier on Windows, Mac OS X, Linux, and Solaris and 10.1.92.10...

9.3 HighFix available

Adobe Flash Player 10.1.82.76 and earlier on Windows, Mac OS X, Linux, and Solaris and 10.1.92.10 on Android; authplay.dll in Adobe Reader and Acrobat 9.x before 9.4; and authplay.dll in Adobe Reader and Acrobat 8.x before 8.2.5 on Windows and Mac OS X allow remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via unspecified vectors, as exploited in the wild in September 2010.

Exploit likelihood

15.6%Up 2.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.3

Adobe Flash Player 10.1.82.76 and earlier on Windows, Mac OS X, Linux, and Solaris and 10.1.92.10 on Android; authplay.dll in Adobe Reader and Acrobat 9.x before 9.4; and authplay.dll in Adobe Reader and Acrobat 8.x before 8.2.5 on Windows and Mac OS X allow remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via unspecified vectors, as exploited in the wild in September 2010.

Record
CVE-2010-2884
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Updated
2026-11-02
CVE List No score

Adobe Flash Player 10.1.82.76 and earlier on Windows, Mac OS X, Linux, and Solaris and 10.1.92.10 on Android; authplay.dll in Adobe Reader and Acrobat 9.x before 9.4; and authplay.dll in Adobe Reader and Acrobat 8.x before 8.2.5 on Windows and Mac OS X allow remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via unspecified vectors, as exploited in the wild in September 2010.

Record
CVE-2010-2884
Updated
2026-11-02
EUVDEUVD-2010-2888 No score

Adobe Flash Player 10.1.82.76 and earlier on Windows, Mac OS X, Linux, and Solaris and 10.1.92.10 on Android; authplay.dll in Adobe Reader and Acrobat 9.x before 9.4; and authplay.dll in Adobe Reader and Acrobat 8.x before 8.2.5 on Windows and Mac OS X allow remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via unspecified vectors, as exploited in the wild in September 2010.

Record
EUVD-2010-2888
Updated
2026-11-03
GitHub AdvisoriesGHSA-v9gp-hvmh-g79c No score

Adobe Flash Player 10.1.82.76 and earlier on Windows, Mac OS X, Linux, and Solaris and 10.1.92.10...

Adobe Flash Player 10.1.82.76 and earlier on Windows, Mac OS X, Linux, and Solaris and 10.1.92.10 on Android; authplay.dll in Adobe Reader and Acrobat 9.x before 9.4; and authplay.dll in Adobe Reader and Acrobat 8.x before 8.2.5 on Windows and Mac OS X allow remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via unspecified vectors, as exploited in the wild in September 2010.

Record
GHSA-v9gp-hvmh-g79c
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
flash-plugin
Red Hat:rhel_extras:3
before 0:9.0.283.0-1.el3.with.oss
0:9.0.283.0-1.el3.with.oss
flash-plugin
Red Hat:rhel_extras:4
before 0:9.0.283.0-1.el4
0:9.0.283.0-1.el4
flash-plugin
Red Hat:rhel_extras:5::client
before 0:10.1.85.3-1.el5
0:10.1.85.3-1.el5
flash-plugin
Red Hat:rhel_extras:5::server
before 0:10.1.85.3-1.el5
0:10.1.85.3-1.el5
acroread
Red Hat:rhel_extras:4
From an advisory covering 19 CVEs
before 0:9.4.0-1.el4
0:9.4.0-1.el4
acroread-plugin
Red Hat:rhel_extras:4
From an advisory covering 19 CVEs
before 0:9.4.0-1.el4
0:9.4.0-1.el4
acroread
Red Hat:rhel_extras:5::client
From an advisory covering 19 CVEs
before 0:9.4.0-1.el5
0:9.4.0-1.el5
acroread-plugin
Red Hat:rhel_extras:5::client
From an advisory covering 19 CVEs
before 0:9.4.0-1.el5
0:9.4.0-1.el5
acroread
Red Hat:rhel_extras:5::server
From an advisory covering 19 CVEs
before 0:9.4.0-1.el5
0:9.4.0-1.el5
acroread-plugin
Red Hat:rhel_extras:5::server
From an advisory covering 19 CVEs
before 0:9.4.0-1.el5
0:9.4.0-1.el5

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2010-2884 is a high vulnerability (CVSS 9.3) in Adobe Acrobat, published September 15, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 15.6%, the 96th percentile. Fixed in flash-plugin 0:9.0.283.0-1.el3.with.oss.

References

Show 89 moreShow less
MoveEnter Open