Every CVE Search/ Get API key

CVE-2010-3070

Cross-site scripting (XSS) vulnerability in NuSOAP 0.9.5, as used in MantisBT and other products,...

4.3 MediumPublic exploitFix available

Cross-site scripting (XSS) vulnerability in NuSOAP 0.9.5, as used in MantisBT and other products, allows remote attackers to inject arbitrary web script or HTML via the PATH_INFO to an arbitrary PHP script that uses NuSOAP classes.

Exploit likelihood

6.16%Down 9.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in NuSOAP 0.9.5, as used in MantisBT and other products, allows remote attackers to inject arbitrary web script or HTML via the PATH_INFO to an arbitrary PHP script that uses NuSOAP classes.

Record
CVE-2010-3070
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in NuSOAP 0.9.5, as used in MantisBT and other products, allows remote attackers to inject arbitrary web script or HTML via the PATH_INFO to an arbitrary PHP script that uses NuSOAP classes.

Record
CVE-2010-3070
Updated
2026-11-02
EUVDEUVD-2010-3072 No score

Cross-site scripting (XSS) vulnerability in NuSOAP 0.9.5, as used in MantisBT and other products, allows remote attackers to inject arbitrary web script or HTML via the PATH_INFO to an arbitrary PHP script that uses NuSOAP classes.

Record
EUVD-2010-3072
Updated
2026-11-03
GitHub AdvisoriesGHSA-fg9p-q5pm-9gpr No score

Cross-site scripting (XSS) vulnerability in NuSOAP 0.9.5, as used in MantisBT and other products,...

Cross-site scripting (XSS) vulnerability in NuSOAP 0.9.5, as used in MantisBT and other products, allows remote attackers to inject arbitrary web script or HTML via the PATH_INFO to an arbitrary PHP script that uses NuSOAP classes.

Record
GHSA-fg9p-q5pm-9gpr
Weakness
CWE-79
Updated
2026-11-02
OSV No score

Cross-site scripting (XSS) vulnerability in NuSOAP 0.9.5, as used in MantisBT and other products, allows remote attackers to inject arbitrary web script or HTML via the PATH_INFO to an arbitrary PHP script that uses NuSOAP classes.

Record
CVE-2010-3070
Updated
2026-11-02
OSVDEBIAN-CVE-2010-3070 No score

Cross-site scripting (XSS) vulnerability in NuSOAP 0.9.5, as used in MantisBT and other products, allows remote attackers to inject arbitrary web script or HTML via the PATH_INFO to an arbitrary PHP script that uses NuSOAP classes.

Record
DEBIAN-CVE-2010-3070
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
nusoap
Debian:12
before 0.7.3-4
0.7.3-4

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBNuSOAP 0.9.5 - 'nusoap.php' Cross-Site Scripting2010-09-03

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2010-3070 is a medium vulnerability (CVSS 4.3) in Dietrich Ayala Nusoap, published September 28, 2010. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 6.16%, the 93rd percentile. Fixed in nusoap 0.7.3-4.

References

Show 23 moreShow less
MoveEnter Open