CVE-2010-3294
Cross-site scripting (XSS) vulnerability in apc.php in the Alternative PHP Cache (APC) extension...
Cross-site scripting (XSS) vulnerability in apc.php in the Alternative PHP Cache (APC) extension before 3.1.4 for PHP allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Exploit likelihood
What each source reports
NVD Score used
4.3
Cross-site scripting (XSS) vulnerability in apc.php in the Alternative PHP Cache (APC) extension before 3.1.4 for PHP allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
CVE-2010-3294- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in apc.php in the Alternative PHP Cache (APC) extension before 3.1.4 for PHP allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
CVE-2010-3294- Updated
- 2026-11-02
EUVDEUVD-2010-3293 No score
Cross-site scripting (XSS) vulnerability in apc.php in the Alternative PHP Cache (APC) extension before 3.1.4 for PHP allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
EUVD-2010-3293- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-96h7-76fj-h8f9 No score
Cross-site scripting (XSS) vulnerability in apc.php in the Alternative PHP Cache (APC) extension...
Cross-site scripting (XSS) vulnerability in apc.php in the Alternative PHP Cache (APC) extension before 3.1.4 for PHP allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
GHSA-96h7-76fj-h8f9- Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
php-pecl-apcRed Hat:enterprise_linux:6::server |
before 0:3.1.9-2.el6 | 0:3.1.9-2.el6 |
php-pecl-apc-debuginfoRed Hat:enterprise_linux:6::server |
before 0:3.1.9-2.el6 | 0:3.1.9-2.el6 |
php-pecl-apc-develRed Hat:enterprise_linux:6::server |
before 0:3.1.9-2.el6 | 0:3.1.9-2.el6 |
php-pecl-apcRed Hat:enterprise_linux:6::workstation |
before 0:3.1.9-2.el6 | 0:3.1.9-2.el6 |
php-pecl-apc-debuginfoRed Hat:enterprise_linux:6::workstation |
before 0:3.1.9-2.el6 | 0:3.1.9-2.el6 |
php-pecl-apc-develRed Hat:enterprise_linux:6::workstation |
before 0:3.1.9-2.el6 | 0:3.1.9-2.el6 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2010-3294 is a medium vulnerability (CVSS 4.3) in Pecl-php Alternative Php Cache, published September 24, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.92%, the 79th percentile. Fixed in php-pecl-apc 0:3.1.9-2.el6.
References
pecl.php.net/package-changelog.php?package=APC&release=3.1.4
vupen.com/english/advisories/2010/2406
openwall.com/lists/oss-security/2010/09/14/6
rhn.redhat.com/errata/RHSA-2012-0811.html
openwall.com/lists/oss-security/2010/09/14/1
openwall.com/lists/oss-security/2010/09/14/8
Show 8 moreShow less
nvd.nist.gov/vuln/detail/CVE-2010-3294
access.redhat.com/errata/RHSA-2012:0811
access.redhat.com/security/cve/CVE-2010-3294
bugzilla.redhat.com/show_bug.cgi?id=634334
github.com/advisories/GHSA-96h7-76fj-h8f9
access.redhat.com/security/updates/classification
security.access.redhat.com/data/csaf/v2/advisories/2012/rhsa-2012_0811.json
cve.org/CVERecord?id=CVE-2010-3294