Every CVE Search/ Get API key

CVE-2010-4203

WebM libvpx (aka the VP8 Codec SDK) before 0.9.5, as used in Google Chrome before 7.0.517.44,...

9.8 CriticalFix available

WebM libvpx (aka the VP8 Codec SDK) before 0.9.5, as used in Google Chrome before 7.0.517.44, allows remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via invalid frames.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

4.57%Down 2.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

WebM libvpx (aka the VP8 Codec SDK) before 0.9.5, as used in Google Chrome before 7.0.517.44, allows remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via invalid frames.

Record
CVE-2010-4203
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-190
Updated
2026-11-02
CVE List No score

WebM libvpx (aka the VP8 Codec SDK) before 0.9.5, as used in Google Chrome before 7.0.517.44, allows remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via invalid frames.

Record
CVE-2010-4203
Updated
2026-11-02
EUVDEUVD-2010-4177 No score

WebM libvpx (aka the VP8 Codec SDK) before 0.9.5, as used in Google Chrome before 7.0.517.44, allows remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via invalid frames.

Record
EUVD-2010-4177
Updated
2026-11-03
GitHub AdvisoriesGHSA-v9gv-2chp-hf2r 9.8

WebM libvpx (aka the VP8 Codec SDK) before 0.9.5, as used in Google Chrome before 7.0.517.44,...

WebM libvpx (aka the VP8 Codec SDK) before 0.9.5, as used in Google Chrome before 7.0.517.44, allows remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via invalid frames.

Record
GHSA-v9gv-2chp-hf2r
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-190
Updated
2026-11-02
OSV 9.8

WebM libvpx (aka the VP8 Codec SDK) before 0.9.5, as used in Google Chrome before 7.0.517.44, allows remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via invalid frames.

Record
CVE-2010-4203
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2010-4203 9.8

WebM libvpx (aka the VP8 Codec SDK) before 0.9.5, as used in Google Chrome before 7.0.517.44, allows remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via invalid frames.

Record
DEBIAN-CVE-2010-4203
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libvpx
Debian:12
before 0.9.1-2
0.9.1-2
libvpx
Debian:13
before 0.9.1-2
0.9.1-2
libvpx
Debian:14
before 0.9.1-2
0.9.1-2
libvpx
Red Hat:enterprise_linux:6::client
before 0:0.9.0-8.el6_0
0:0.9.0-8.el6_0
libvpx-debuginfo
Red Hat:enterprise_linux:6::client
before 0:0.9.0-8.el6_0
0:0.9.0-8.el6_0
libvpx-devel
Red Hat:enterprise_linux:6::client
before 0:0.9.0-8.el6_0
0:0.9.0-8.el6_0
libvpx-utils
Red Hat:enterprise_linux:6::client
before 0:0.9.0-8.el6_0
0:0.9.0-8.el6_0
libvpx
Red Hat:enterprise_linux:6::server
before 0:0.9.0-8.el6_0
0:0.9.0-8.el6_0
libvpx-debuginfo
Red Hat:enterprise_linux:6::server
before 0:0.9.0-8.el6_0
0:0.9.0-8.el6_0
libvpx-devel
Red Hat:enterprise_linux:6::server
before 0:0.9.0-8.el6_0
0:0.9.0-8.el6_0
Show 5 moreShow less
Affected packages
PackageAffectedFixed
libvpx-utils
Red Hat:enterprise_linux:6::server
before 0:0.9.0-8.el6_0
0:0.9.0-8.el6_0
libvpx
Red Hat:enterprise_linux:6::workstation
before 0:0.9.0-8.el6_0
0:0.9.0-8.el6_0
libvpx-debuginfo
Red Hat:enterprise_linux:6::workstation
before 0:0.9.0-8.el6_0
0:0.9.0-8.el6_0
libvpx-devel
Red Hat:enterprise_linux:6::workstation
before 0:0.9.0-8.el6_0
0:0.9.0-8.el6_0
libvpx-utils
Red Hat:enterprise_linux:6::workstation
before 0:0.9.0-8.el6_0
0:0.9.0-8.el6_0

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2010-4203 is a critical vulnerability (CVSS 9.8) in Google Chrome, published November 5, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.57%, the 91st percentile. Fixed in libvpx 0.9.1-2.

References

Show 17 moreShow less
MoveEnter Open