Every CVE Search/ Get API key

CVE-2010-4555

Multiple cross-site scripting (XSS) vulnerabilities in SquirrelMail 1.4.21 and earlier allow...

4.3 MediumFix available

Multiple cross-site scripting (XSS) vulnerabilities in SquirrelMail 1.4.21 and earlier allow remote attackers to inject arbitrary web script or HTML via vectors involving (1) drop-down selection lists, (2) the > (greater than) character in the SquirrelSpell spellchecking plugin, and (3) errors associated with the Index Order (aka options_order) page.

Exploit likelihood

2.35%Up 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Multiple cross-site scripting (XSS) vulnerabilities in SquirrelMail 1.4.21 and earlier allow remote attackers to inject arbitrary web script or HTML via vectors involving (1) drop-down selection lists, (2) the > (greater than) character in the SquirrelSpell spellchecking plugin, and (3) errors associated with the Index Order (aka options_order) page.

Record
CVE-2010-4555
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Multiple cross-site scripting (XSS) vulnerabilities in SquirrelMail 1.4.21 and earlier allow remote attackers to inject arbitrary web script or HTML via vectors involving (1) drop-down selection lists, (2) the > (greater than) character in the SquirrelSpell spellchecking plugin, and (3) errors associated with the Index Order (aka options_order) page.

Record
CVE-2010-4555
Updated
2026-11-02
EUVDEUVD-2010-4521 No score

Multiple cross-site scripting (XSS) vulnerabilities in SquirrelMail 1.4.21 and earlier allow remote attackers to inject arbitrary web script or HTML via vectors involving (1) drop-down selection lists, (2) the > (greater than) character in the SquirrelSpell spellchecking plugin, and (3) errors associated with the Index Order (aka options_order) page.

Record
EUVD-2010-4521
Updated
2026-11-03
GitHub AdvisoriesGHSA-cwvc-h2j5-j87h No score

Multiple cross-site scripting (XSS) vulnerabilities in SquirrelMail 1.4.21 and earlier allow...

Multiple cross-site scripting (XSS) vulnerabilities in SquirrelMail 1.4.21 and earlier allow remote attackers to inject arbitrary web script or HTML via vectors involving (1) drop-down selection lists, (2) the > (greater than) character in the SquirrelSpell spellchecking plugin, and (3) errors associated with the Index Order (aka options_order) page.

Record
GHSA-cwvc-h2j5-j87h
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
squirrelmail
Debian:5.0
before 2:1.4.15-4+lenny5, plus listed versions
2:1.4.15-42:1.4.15-4+lenny12:1.4.15-4+lenny22:1.4.15-4+lenny3.1
2:1.4.15-4+lenny5
squirrelmail
Debian:6.0
before 2:1.4.21-2, plus listed versions
2:1.4.21-1
2:1.4.21-2
squirrelmail
Red Hat:enterprise_linux:4::as
before 0:1.4.8-18.el4
0:1.4.8-18.el4
squirrelmail
Red Hat:enterprise_linux:4::desktop
before 0:1.4.8-18.el4
0:1.4.8-18.el4
squirrelmail
Red Hat:enterprise_linux:4::es
before 0:1.4.8-18.el4
0:1.4.8-18.el4
squirrelmail
Red Hat:enterprise_linux:4::ws
before 0:1.4.8-18.el4
0:1.4.8-18.el4
squirrelmail
Red Hat:enterprise_linux:5::client_workstation
before 0:1.4.8-5.el5_7.13
0:1.4.8-5.el5_7.13
squirrelmail
Red Hat:enterprise_linux:5::server
before 0:1.4.8-5.el5_7.13
0:1.4.8-5.el5_7.13

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2010-4555 is a medium vulnerability (CVSS 4.3) in Squirrelmail, published July 14, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.35%, the 83rd percentile. Fixed in squirrelmail 2:1.4.15-4+lenny5.

References

Show 39 moreShow less
MoveEnter Open