Every CVE Search/ Get API key

CVE-2011-0050

Cross-site scripting (XSS) vulnerability in the nonjs interface (interfaces/nonjs.pm) in CGI:IRC...

4.3 MediumFix available

Cross-site scripting (XSS) vulnerability in the nonjs interface (interfaces/nonjs.pm) in CGI:IRC before 0.5.10 allows remote attackers to inject arbitrary web script or HTML via the R parameter.

Exploit likelihood

2.66%Up 1.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in the nonjs interface (interfaces/nonjs.pm) in CGI:IRC before 0.5.10 allows remote attackers to inject arbitrary web script or HTML via the R parameter.

Record
CVE-2011-0050
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in the nonjs interface (interfaces/nonjs.pm) in CGI:IRC before 0.5.10 allows remote attackers to inject arbitrary web script or HTML via the R parameter.

Record
CVE-2011-0050
Updated
2026-11-02
EUVDEUVD-2011-0076 No score

Cross-site scripting (XSS) vulnerability in the nonjs interface (interfaces/nonjs.pm) in CGI:IRC before 0.5.10 allows remote attackers to inject arbitrary web script or HTML via the R parameter.

Record
EUVD-2011-0076
Updated
2026-11-03
GitHub AdvisoriesGHSA-xw49-5924-343v No score

Cross-site scripting (XSS) vulnerability in the nonjs interface (interfaces/nonjs.pm) in CGI:IRC...

Cross-site scripting (XSS) vulnerability in the nonjs interface (interfaces/nonjs.pm) in CGI:IRC before 0.5.10 allows remote attackers to inject arbitrary web script or HTML via the R parameter.

Record
GHSA-xw49-5924-343v
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
cgiirc
Debian:5.0
before 0.5.9-3lenny3, plus listed versions
0.5.9-30.5.9-3lenny1
0.5.9-3lenny3
cgiirc
Debian:6.0
before 0.5.9-3squeeze1, plus listed versions
0.5.9-30.5.9-3lenny10.5.9-3lenny3
0.5.9-3squeeze1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-0050 is a medium vulnerability (CVSS 4.3) in Cgiirc Cgi\, published February 9, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.66%, the 85th percentile. Fixed in cgiirc 0.5.9-3lenny3.

References

MoveEnter Open