Every CVE Search/ Get API key

CVE-2011-0533

Apache Continuum and Archiva vulnerable to Cross-site Scripting

4.3 MediumFix available

Cross-site scripting (XSS) vulnerability in Apache Continuum 1.1 through 1.2.3.1, 1.3.6, and 1.4.0 Beta; and Archiva 1.3.0 through 1.3.3 and 1.0 through 1.22 allows remote attackers to inject arbitrary web script or HTML via a crafted parameter, related to the autoIncludeParameters setting for the extremecomponents table.

Exploit likelihood

4.20%Down 2.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in Apache Continuum 1.1 through 1.2.3.1, 1.3.6, and 1.4.0 Beta; and Archiva 1.3.0 through 1.3.3 and 1.0 through 1.22 allows remote attackers to inject arbitrary web script or HTML via a crafted parameter, related to the autoIncludeParameters setting for the extremecomponents table.

Record
CVE-2011-0533
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in Apache Continuum 1.1 through 1.2.3.1, 1.3.6, and 1.4.0 Beta; and Archiva 1.3.0 through 1.3.3 and 1.0 through 1.22 allows remote attackers to inject arbitrary web script or HTML via a crafted parameter, related to the autoIncludeParameters setting for the extremecomponents table.

Record
CVE-2011-0533
Updated
2026-11-02
EUVDEUVD-2011-0552 No score

Cross-site scripting (XSS) vulnerability in Apache Continuum 1.1 through 1.2.3.1, 1.3.6, and 1.4.0 Beta; and Archiva 1.3.0 through 1.3.3 and 1.0 through 1.22 allows remote attackers to inject arbitrary web script or HTML via a crafted parameter, related to the autoIncludeParameters setting for the extremecomponents table.

Record
EUVD-2011-0552
Updated
2026-11-03
GitHub AdvisoriesGHSA-7382-fv7p-v9v3 No score

Apache Continuum and Archiva vulnerable to Cross-site Scripting

Cross-site scripting (XSS) vulnerability in Apache Continuum 1.1 through 1.2.3.1, 1.3.6, and 1.4.0 Beta; and Archiva 1.3.0 through 1.3.3 and 1.0 through 1.2.2 allows remote attackers to inject arbitrary web script or HTML via a crafted parameter, related to the autoIncludeParameters setting for the extremecomponents table.

Record
GHSA-7382-fv7p-v9v3
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-7382-fv7p-v9v3 No score

Apache Continuum and Archiva vulnerable to Cross-site Scripting

Cross-site scripting (XSS) vulnerability in Apache Continuum 1.1 through 1.2.3.1, 1.3.6, and 1.4.0 Beta; and Archiva 1.3.0 through 1.3.3 and 1.0 through 1.2.2 allows remote attackers to inject arbitrary web script or HTML via a crafted parameter, related to the autoIncludeParameters setting for the extremecomponents table.

Record
GHSA-7382-fv7p-v9v3
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.archiva:archiva
Maven
1.0 up to 1.3.4
1.3.4
org.apache.continuum:continuum
Maven
1.1 up to 1.3.7
1.3.7
org.apache.continuum:continuum
Maven
1.4.0-beta to 1.4.0-beta None known
org.apache.archiva:archiva
Maven
1.0 up to 1.3.4, plus listed versions
1.11.1.11.1.21.1.31.1.4
Show 8 moreShow less
1.21.2-M11.2.11.2.21.31.3.11.3.21.3.3
1.3.4
org.apache.continuum:continuum
Maven
1.1 up to 1.3.7, plus listed versions
1.21.2.21.2.31.3.11.3.2
Show 4 moreShow less
1.3.31.3.41.3.51.3.6
1.3.7
org.apache.continuum:continuum
Maven
Listed versions
1.4.0-beta
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-0533 is a medium vulnerability (CVSS 4.3) in Apache Archiva, published February 17, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.20%, the 90th percentile. Fixed in org.apache.archiva:archiva 1.3.4.

References

Show 20 moreShow less
MoveEnter Open