Every CVE Search/ Get API key

CVE-2011-1153

Multiple format string vulnerabilities in phar_object.c in the phar extension in PHP 5.3.5 and...

7.5 High

Multiple format string vulnerabilities in phar_object.c in the phar extension in PHP 5.3.5 and earlier allow context-dependent attackers to obtain sensitive information from process memory, cause a denial of service (memory corruption), or possibly execute arbitrary code via format string specifiers in an argument to a class method, leading to an incorrect zend_throw_exception_ex call.

Exploit likelihood

6.83%Up 2.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Multiple format string vulnerabilities in phar_object.c in the phar extension in PHP 5.3.5 and earlier allow context-dependent attackers to obtain sensitive information from process memory, cause a denial of service (memory corruption), or possibly execute arbitrary code via format string specifiers in an argument to a class method, leading to an incorrect zend_throw_exception_ex call.

Record
CVE-2011-1153
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-134
Updated
2026-11-02
CVE List No score

Multiple format string vulnerabilities in phar_object.c in the phar extension in PHP 5.3.5 and earlier allow context-dependent attackers to obtain sensitive information from process memory, cause a denial of service (memory corruption), or possibly execute arbitrary code via format string specifiers in an argument to a class method, leading to an incorrect zend_throw_exception_ex call.

Record
CVE-2011-1153
Updated
2026-11-02
EUVDEUVD-2011-1166 No score

Multiple format string vulnerabilities in phar_object.c in the phar extension in PHP 5.3.5 and earlier allow context-dependent attackers to obtain sensitive information from process memory, cause a denial of service (memory corruption), or possibly execute arbitrary code via format string specifiers in an argument to a class method, leading to an incorrect zend_throw_exception_ex call.

Record
EUVD-2011-1166
Updated
2026-11-03
GitHub AdvisoriesGHSA-p2q6-4rhc-9fhc No score

Multiple format string vulnerabilities in phar_object.c in the phar extension in PHP 5.3.5 and...

Multiple format string vulnerabilities in phar_object.c in the phar extension in PHP 5.3.5 and earlier allow context-dependent attackers to obtain sensitive information from process memory, cause a denial of service (memory corruption), or possibly execute arbitrary code via format string specifiers in an argument to a class method, leading to an incorrect zend_throw_exception_ex call.

Record
GHSA-p2q6-4rhc-9fhc
Weakness
CWE-134
Updated
2026-11-02
OSVopenSUSE-SU-2024:10290-1 No score

apache2-mod_php7-7.0.14-1.4 on GA media

These are all security issues fixed in the apache2-mod_php7-7.0.14-1.4 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10290-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:10344-1 No score

apache2-mod_php5-5.6.28-1.1 on GA media

These are all security issues fixed in the apache2-mod_php5-5.6.28-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10344-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:11169-1 No score

php8-8.0.11-1.1 on GA media

These are all security issues fixed in the php8-8.0.11-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11169-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
php5
Debian:5.0
From an advisory covering 8 CVEs
before 5.2.6.dfsg.1-1+lenny12, plus listed versions
5.2.6.dfsg.1-1+lenny105.2.6.dfsg.1-1+lenny115.2.6.dfsg.1-1+lenny25.2.6.dfsg.1-1+lenny35.2.6.dfsg.1-1+lenny45.2.6.dfsg.1-1+lenny65.2.6.dfsg.1-1+lenny85.2.6.dfsg.1-1+lenny9
5.2.6.dfsg.1-1+lenny12
php5
Debian:6.0
From an advisory covering 8 CVEs
before 5.3.3-7+squeeze3, plus listed versions
5.3.3-75.3.3-7+squeeze15.3.3-7+squeeze2
5.3.3-7+squeeze3
php7
openSUSE:Tumbleweed
From an advisory covering 70 CVEs
before 7.0.14-1.4
7.0.14-1.4
php5
openSUSE:Tumbleweed
From an advisory covering 71 CVEs
before 5.6.28-1.1
5.6.28-1.1
php8
openSUSE:Tumbleweed
From an advisory covering 97 CVEs
before 8.0.11-1.1
8.0.11-1.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-1153 is a high vulnerability (CVSS 7.5) in Php, published March 16, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.83%, the 94th percentile. No source names a fixed version.

References

Show 134 moreShow less
MoveEnter Open