Every CVE Search/ Get API key

CVE-2011-1477

Multiple array index errors in sound/oss/opl3.c in the Linux kernel before 2.6.39 allow local...

7.2 High

Multiple array index errors in sound/oss/opl3.c in the Linux kernel before 2.6.39 allow local users to cause a denial of service (heap memory corruption) or possibly gain privileges by leveraging write access to /dev/sequencer.

Exploit likelihood

0.41%Down 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.2

Multiple array index errors in sound/oss/opl3.c in the Linux kernel before 2.6.39 allow local users to cause a denial of service (heap memory corruption) or possibly gain privileges by leveraging write access to /dev/sequencer.

Record
CVE-2011-1477
CVSS 2.0
7.2 HighAV:L/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-119, CWE-264
Updated
2026-11-02
CVE List No score

Multiple array index errors in sound/oss/opl3.c in the Linux kernel before 2.6.39 allow local users to cause a denial of service (heap memory corruption) or possibly gain privileges by leveraging write access to /dev/sequencer.

Record
CVE-2011-1477
Updated
2026-11-02
EUVDEUVD-2011-1481 No score

Multiple array index errors in sound/oss/opl3.c in the Linux kernel before 2.6.39 allow local users to cause a denial of service (heap memory corruption) or possibly gain privileges by leveraging write access to /dev/sequencer.

Record
EUVD-2011-1481
Updated
2026-11-03
GitHub AdvisoriesGHSA-9cxg-mgw2-24vg No score

Multiple array index errors in sound/oss/opl3.c in the Linux kernel before 2.6.39 allow local...

Multiple array index errors in sound/oss/opl3.c in the Linux kernel before 2.6.39 allow local users to cause a denial of service (heap memory corruption) or possibly gain privileges by leveraging write access to /dev/sequencer.

Record
GHSA-9cxg-mgw2-24vg
Weakness
CWE-119
Updated
2026-11-02
OSVSUSE-SU-2015:0652-1 No score

Security update for Kernel

The SUSE Linux Enterprise 11 SP1 Teradata kernel was updated to fix bugs and security issues.

Following security issues were fixed:

CVE-2011-1083: Limit the path length users can build using epoll() to avoid local attackers consuming lots of kernel CPU time.

CVE-2011-4086: Fixed a oops in jbd/jbd2 that could be caused by specific filesystem access patterns.

CVE-2011-4622: KVM: Prevent starting PIT timers in the absence of irqchip support.

CVE-2012-0045: KVM: Extend 'struct x86_emulate_ops' with 'get_cpuid' and fix missing checks in syscall emulation.

CVE-2012-0879: Fix io_context leak after clone with CLONE_IO.

CVE-2012-1090: Fixed a dentry refcount leak in the CIFS file system that could lead to a crash on unmount.

CVE-2012-1097: The regset common infrastructure assumed that regsets would always have .get and .set methods, but necessarily .active methods. Unfortunately people have since written regsets without .set method, so NULL pointer dereference attacks were possible.

Following non-security issues were fixed:

* SCSI inquiry doesn't return data on SLES 11-SP1 Xen VMs (bnc#745929).
* FC transport driver killing off the timers/work queues (bnc#734300).
* The driver ixgbevf doesn't work on newer SLES 11-SP1 kernels
  (bnc#752972).
* Pack sparsemem memmap sections closer together and in higher zones
  (bnc#743870).

Following feature was implemented:

* The megaraid_sas driver update to version 5.40-LSI (bnc#736813).

Security Issues:

* CVE-2011-1083
  <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-1083>
* CVE-2011-4086
  <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-4086>
* CVE-2011-4622
  <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-4622>
* CVE-2012-0045
  <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-0045>
* CVE-2012-0879
  <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-0879>
* CVE-2012-1090
  <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-1090>
* CVE-2012-1097
  <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-1097>
Record
SUSE-SU-2015:0652-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
linux-2.6
Debian:6.0
From an advisory covering 36 CVEs
before 2.6.32-34squeeze1, plus listed versions
2.6.32-302.6.32-30+m68k.52.6.32-312.6.32-31~bpo50+12.6.32-322.6.32-332.6.32-34
2.6.32-34squeeze1
linux-2.6
Debian:5.0
From an advisory covering 39 CVEs
before 2.6.26-26lenny3, plus listed versions
2.6.26-132.6.26-13lenny22.6.26-13lenny2~bpo40+12.6.26-142.6.26-15
Show 34 moreShow less
2.6.26-15lenny12.6.26-15lenny22.6.26-15lenny32.6.26-15~bpo40+12.6.26-15~bpo40+22.6.26-162.6.26-172.6.26-17lenny12.6.26-17lenny22.6.26-17lenny2~bpo40+12.6.26-17~bpo40+12.6.26-182.6.26-192.6.26-19lenny12.6.26-19lenny22.6.26-19~bpo40+12.6.26-202.6.26-20~bpo40+12.6.26-212.6.26-21lenny12.6.26-21lenny22.6.26-21lenny32.6.26-21lenny42.6.26-21~bpo40+12.6.26-222.6.26-22lenny12.6.26-232.6.26-242.6.26-24lenny12.6.26-252.6.26-25lenny12.6.26-262.6.26-26lenny12.6.26-26lenny2
2.6.26-26lenny3

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-1477 is a high vulnerability (CVSS 7.2) in Linux Kernel, published May 23, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.41%, the 35th percentile. No source names a fixed version.

References

Show 194 moreShow less
This page doesn't list everything

Left out here: 877 references. The JSON record has them.

MoveEnter Open