Every CVE Search/ Get API key

CVE-2011-1580

The transwiki import functionality in MediaWiki before 1.16.3 does not properly check privileges,...

3.5 LowFix available

The transwiki import functionality in MediaWiki before 1.16.3 does not properly check privileges, which allows remote authenticated users to perform imports from any wgImportSources wiki via a crafted POST request.

Exploit likelihood

2.01%Down 0.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 3.5

The transwiki import functionality in MediaWiki before 1.16.3 does not properly check privileges, which allows remote authenticated users to perform imports from any wgImportSources wiki via a crafted POST request.

Record
CVE-2011-1580
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

The transwiki import functionality in MediaWiki before 1.16.3 does not properly check privileges, which allows remote authenticated users to perform imports from any wgImportSources wiki via a crafted POST request.

Record
CVE-2011-1580
Updated
2026-11-02
EUVDEUVD-2011-1581 No score

The transwiki import functionality in MediaWiki before 1.16.3 does not properly check privileges, which allows remote authenticated users to perform imports from any wgImportSources wiki via a crafted POST request.

Record
EUVD-2011-1581
Updated
2026-11-03
GitHub AdvisoriesGHSA-5f9r-6cq4-fph8 No score

The transwiki import functionality in MediaWiki before 1.16.3 does not properly check privileges,...

The transwiki import functionality in MediaWiki before 1.16.3 does not properly check privileges, which allows remote authenticated users to perform imports from any wgImportSources wiki via a crafted POST request.

Record
GHSA-5f9r-6cq4-fph8
Weakness
CWE-20
Updated
2026-11-02
OSV No score

The transwiki import functionality in MediaWiki before 1.16.3 does not properly check privileges, which allows remote authenticated users to perform imports from any wgImportSources wiki via a crafted POST request.

Record
CVE-2011-1580
Updated
2026-11-02
OSVDEBIAN-CVE-2011-1580 No score

The transwiki import functionality in MediaWiki before 1.16.3 does not properly check privileges, which allows remote authenticated users to perform imports from any wgImportSources wiki via a crafted POST request.

Record
DEBIAN-CVE-2011-1580
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mediawiki
Debian:12
before 1:1.15.5-5
1:1.15.5-5
mediawiki
Debian:13
before 1:1.15.5-5
1:1.15.5-5
mediawiki
Debian:14
before 1:1.15.5-5
1:1.15.5-5
mediawiki
Debian:6.0
From an advisory covering 6 CVEs
before 1:1.15.5-2squeeze2, plus listed versions
1:1.15.5-21:1.15.5-2squeeze1
1:1.15.5-2squeeze2
mediawiki
Debian:5.0
From an advisory covering 6 CVEs
before 1:1.12.0-2lenny9, plus listed versions
1:1.12.0-2lenny21:1.12.0-2lenny31:1.12.0-2lenny3~bpo40+11:1.12.0-2lenny41:1.12.0-2lenny51:1.12.0-2lenny61:1.12.0-2lenny71:1.12.0-2lenny8
1:1.12.0-2lenny9

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-1580 is a low vulnerability (CVSS 3.5) in Mediawiki, published April 27, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.01%, the 80th percentile. Fixed in mediawiki 1:1.15.5-5.

References

Show 13 moreShow less
MoveEnter Open