CVE-2011-1753
expat_erl.c in ejabberd before 2.1.7 and 3.x before 3.0.0-alpha-3, and exmpp before 0.9.7, does...
expat_erl.c in ejabberd before 2.1.7 and 3.x before 3.0.0-alpha-3, and exmpp before 0.9.7, does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.
Exploit likelihood
What each source reports
NVD Score used
5.0
expat_erl.c in ejabberd before 2.1.7 and 3.x before 3.0.0-alpha-3, and exmpp before 0.9.7, does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.
- Record
CVE-2011-1753- CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-399
- Updated
- 2026-11-02
CVE List No score
expat_erl.c in ejabberd before 2.1.7 and 3.x before 3.0.0-alpha-3, and exmpp before 0.9.7, does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.
- Record
CVE-2011-1753- Updated
- 2026-11-02
EUVDEUVD-2011-1752 No score
expat_erl.c in ejabberd before 2.1.7 and 3.x before 3.0.0-alpha-3, and exmpp before 0.9.7, does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.
- Record
EUVD-2011-1752- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-35cw-298h-r635 No score
expat_erl.c in ejabberd before 2.1.7 and 3.x before 3.0.0-alpha-3, and exmpp before 0.9.7, does...
expat_erl.c in ejabberd before 2.1.7 and 3.x before 3.0.0-alpha-3, and exmpp before 0.9.7, does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.
- Record
GHSA-35cw-298h-r635- Updated
- 2026-11-02
OSV No score
expat_erl.c in ejabberd before 2.1.7 and 3.x before 3.0.0-alpha-3, and exmpp before 0.9.7, does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.
- Record
CVE-2011-1753- Updated
- 2026-11-02
OSVDEBIAN-CVE-2011-1753 No score
expat_erl.c in ejabberd before 2.1.7 and 3.x before 3.0.0-alpha-3, and exmpp before 0.9.7, does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.
- Record
DEBIAN-CVE-2011-1753- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ejabberdDebian:12 |
before 2.1.6-2.1 | 2.1.6-2.1 |
ejabberdDebian:13 |
before 2.1.6-2.1 | 2.1.6-2.1 |
ejabberdDebian:14 |
before 2.1.6-2.1 | 2.1.6-2.1 |
ejabberdDebian:6.0 |
before 2.1.5-3+squeeze1, plus listed versions 2.1.5-32.1.5-3+squeeze1~bpo50+1 |
2.1.5-3+squeeze1 |
ejabberdDebian:5.0 |
before 2.0.1-6+lenny3, plus listed versions 2.0.1-52.0.1-62.0.1-6+lenny12.0.1-6+lenny1~bpo40+12.0.1-6+lenny22.0.1-6~bpo40+1 |
2.0.1-6+lenny3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2011-1753 is a medium vulnerability (CVSS 5.0) in Process-one Ejabberd, published May 31, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.12%, the 81st percentile. Fixed in ejabberd 2.1.6-2.1.
References
exchange.xforce.ibmcloud.com/vulnerabilities/67769
debian.org/security/2011/dsa-2248
process-one.net/en/ejabberd/release_notes/release_note_ejabberd_2.1.7
secunia.com/advisories/44765
git.process-one.net/ejabberd/mainline/commit/bd1df027c622e1f96f9eeaac612a6a956c1ff0b6
lists.fedoraproject.org/pipermail/package-announce/2011-June/062099.html
Show 9 moreShow less
ejabberd.im/ejabberd-2.1.7
bugzilla.redhat.com/show_bug.cgi?id=700454
secunia.com/advisories/44807
securityfocus.com/bid/48072
lists.fedoraproject.org/pipermail/package-announce/2011-June/062145.html
secunia.com/advisories/45120
nvd.nist.gov/vuln/detail/CVE-2011-1753
github.com/advisories/GHSA-35cw-298h-r635
security-tracker.debian.org/tracker/CVE-2011-1753