Every CVE Search/ Get API key

CVE-2011-2023

Cross-site scripting (XSS) vulnerability in functions/mime.php in SquirrelMail before 1.4.22...

4.3 MediumFix available

Cross-site scripting (XSS) vulnerability in functions/mime.php in SquirrelMail before 1.4.22 allows remote attackers to inject arbitrary web script or HTML via a crafted STYLE element in an e-mail message.

Exploit likelihood

2.32%Up 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in functions/mime.php in SquirrelMail before 1.4.22 allows remote attackers to inject arbitrary web script or HTML via a crafted STYLE element in an e-mail message.

Record
CVE-2011-2023
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in functions/mime.php in SquirrelMail before 1.4.22 allows remote attackers to inject arbitrary web script or HTML via a crafted STYLE element in an e-mail message.

Record
CVE-2011-2023
Updated
2026-11-02
EUVDEUVD-2011-2017 No score

Cross-site scripting (XSS) vulnerability in functions/mime.php in SquirrelMail before 1.4.22 allows remote attackers to inject arbitrary web script or HTML via a crafted STYLE element in an e-mail message.

Record
EUVD-2011-2017
Updated
2026-11-03
GitHub AdvisoriesGHSA-p9fx-gwhc-6m8m No score

Cross-site scripting (XSS) vulnerability in functions/mime.php in SquirrelMail before 1.4.22...

Cross-site scripting (XSS) vulnerability in functions/mime.php in SquirrelMail before 1.4.22 allows remote attackers to inject arbitrary web script or HTML via a crafted STYLE element in an e-mail message.

Record
GHSA-p9fx-gwhc-6m8m
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
squirrelmail
Debian:5.0
before 2:1.4.15-4+lenny5, plus listed versions
2:1.4.15-42:1.4.15-4+lenny12:1.4.15-4+lenny22:1.4.15-4+lenny3.1
2:1.4.15-4+lenny5
squirrelmail
Debian:6.0
before 2:1.4.21-2, plus listed versions
2:1.4.21-1
2:1.4.21-2
squirrelmail
Red Hat:enterprise_linux:4::as
before 0:1.4.8-18.el4
0:1.4.8-18.el4
squirrelmail
Red Hat:enterprise_linux:4::desktop
before 0:1.4.8-18.el4
0:1.4.8-18.el4
squirrelmail
Red Hat:enterprise_linux:4::es
before 0:1.4.8-18.el4
0:1.4.8-18.el4
squirrelmail
Red Hat:enterprise_linux:4::ws
before 0:1.4.8-18.el4
0:1.4.8-18.el4
squirrelmail
Red Hat:enterprise_linux:5::client_workstation
before 0:1.4.8-5.el5_7.13
0:1.4.8-5.el5_7.13
squirrelmail
Red Hat:enterprise_linux:5::server
before 0:1.4.8-5.el5_7.13
0:1.4.8-5.el5_7.13

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-2023 is a medium vulnerability (CVSS 4.3) in Squirrelmail, published July 14, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.32%, the 83rd percentile. Fixed in squirrelmail 2:1.4.15-4+lenny5.

References

Show 38 moreShow less
MoveEnter Open