Every CVE Search/ Get API key

CVE-2011-2188

LuaExpat before 1.2.0 does not properly detect recursion during entity expansion, which allows...

5.0 MediumFix available

LuaExpat before 1.2.0 does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.

Exploit likelihood

1.75%Up 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

LuaExpat before 1.2.0 does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.

Record
CVE-2011-2188
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-399
Updated
2026-11-02
CVE List No score

LuaExpat before 1.2.0 does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.

Record
CVE-2011-2188
Updated
2026-11-02
EUVDEUVD-2011-2179 No score

LuaExpat before 1.2.0 does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.

Record
EUVD-2011-2179
Updated
2026-11-03
GitHub AdvisoriesGHSA-827g-rqf3-jrp6 No score

LuaExpat before 1.2.0 does not properly detect recursion during entity expansion, which allows...

LuaExpat before 1.2.0 does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.

Record
GHSA-827g-rqf3-jrp6
Updated
2026-11-02
OSV No score

LuaExpat before 1.2.0 does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.

Record
CVE-2011-2188
Updated
2026-11-02
OSVDEBIAN-CVE-2011-2188 No score

LuaExpat before 1.2.0 does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.

Record
DEBIAN-CVE-2011-2188
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
lua-expat
Debian:12
before 1.2.0-1
1.2.0-1
lua-expat
Debian:13
before 1.2.0-1
1.2.0-1
lua-expat
Debian:14
before 1.2.0-1
1.2.0-1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-2188 is a medium vulnerability (CVSS 5.0) in Matthewwild Luaexpat, published June 21, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.75%, the 77th percentile. Fixed in lua-expat 1.2.0-1.

References

Show 4 moreShow less
MoveEnter Open