Every CVE Search/ Get API key

CVE-2011-2486

nspluginwrapper before 1.4.4 does not properly provide access to NPNVprivateModeBool variable...

5.0 MediumFix available

nspluginwrapper before 1.4.4 does not properly provide access to NPNVprivateModeBool variable settings, which could prevent Firefox plugins from determining if they should run in Private Browsing mode and allow remote attackers to bypass intended access restrictions, as demonstrated using Flash.

Exploit likelihood

2.47%Up 1.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

nspluginwrapper before 1.4.4 does not properly provide access to NPNVprivateModeBool variable settings, which could prevent Firefox plugins from determining if they should run in Private Browsing mode and allow remote attackers to bypass intended access restrictions, as demonstrated using Flash.

Record
CVE-2011-2486
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

nspluginwrapper before 1.4.4 does not properly provide access to NPNVprivateModeBool variable settings, which could prevent Firefox plugins from determining if they should run in Private Browsing mode and allow remote attackers to bypass intended access restrictions, as demonstrated using Flash.

Record
CVE-2011-2486
Updated
2026-11-02
EUVDEUVD-2011-2474 No score

nspluginwrapper before 1.4.4 does not properly provide access to NPNVprivateModeBool variable settings, which could prevent Firefox plugins from determining if they should run in Private Browsing mode and allow remote attackers to bypass intended access restrictions, as demonstrated using Flash.

Record
EUVD-2011-2474
Updated
2026-11-03
GitHub AdvisoriesGHSA-fvm8-v4j9-jgp3 No score

nspluginwrapper before 1.4.4 does not properly provide access to NPNVprivateModeBool variable...

nspluginwrapper before 1.4.4 does not properly provide access to NPNVprivateModeBool variable settings, which could prevent Firefox plugins from determining if they should run in Private Browsing mode and allow remote attackers to bypass intended access restrictions, as demonstrated using Flash.

Record
GHSA-fvm8-v4j9-jgp3
Updated
2026-11-02
OSVopenSUSE-SU-2024:10270-1 No score

nspluginwrapper-1.4.4-16.6 on GA media

These are all security issues fixed in the nspluginwrapper-1.4.4-16.6 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10270-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
nspluginwrapper
Red Hat:enterprise_linux:6::client
before 0:1.4.4-1.el6_3
0:1.4.4-1.el6_3
nspluginwrapper-debuginfo
Red Hat:enterprise_linux:6::client
before 0:1.4.4-1.el6_3
0:1.4.4-1.el6_3
nspluginwrapper
Red Hat:enterprise_linux:6::computenode
before 0:1.4.4-1.el6_3
0:1.4.4-1.el6_3
nspluginwrapper-debuginfo
Red Hat:enterprise_linux:6::computenode
before 0:1.4.4-1.el6_3
0:1.4.4-1.el6_3
nspluginwrapper
Red Hat:enterprise_linux:6::server
before 0:1.4.4-1.el6_3
0:1.4.4-1.el6_3
nspluginwrapper-debuginfo
Red Hat:enterprise_linux:6::server
before 0:1.4.4-1.el6_3
0:1.4.4-1.el6_3
nspluginwrapper
Red Hat:enterprise_linux:6::workstation
before 0:1.4.4-1.el6_3
0:1.4.4-1.el6_3
nspluginwrapper-debuginfo
Red Hat:enterprise_linux:6::workstation
before 0:1.4.4-1.el6_3
0:1.4.4-1.el6_3
nspluginwrapper
openSUSE:Tumbleweed
before 1.4.4-16.6
1.4.4-16.6

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-2486 is a medium vulnerability (CVSS 5.0) in Nspluginwrapper, published November 19, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.47%, the 84th percentile. Fixed in nspluginwrapper 0:1.4.4-1.el6_3.

References

Show 8 moreShow less
MoveEnter Open