CVE-2011-2719
libraries/auth/swekey/swekey.auth.lib.php in phpMyAdmin 3.x before 3.3.10.3 and 3.4.x before 3.4...
libraries/auth/swekey/swekey.auth.lib.php in phpMyAdmin 3.x before 3.3.10.3 and 3.4.x before 3.4.3.2 does not properly manage sessions associated with Swekey authentication, which allows remote attackers to modify the SESSION superglobal array, other superglobal arrays, and certain swekey.auth.lib.php local variables via a crafted query string, a related issue to CVE-2011-2505.
Exploit likelihood
What each source reports
NVD Score used
6.4
libraries/auth/swekey/swekey.auth.lib.php in phpMyAdmin 3.x before 3.3.10.3 and 3.4.x before 3.4.3.2 does not properly manage sessions associated with Swekey authentication, which allows remote attackers to modify the SESSION superglobal array, other superglobal arrays, and certain swekey.auth.lib.php local variables via a crafted query string, a related issue to CVE-2011-2505.
- Record
CVE-2011-2719- CVSS 2.0
- 6.4 Medium
AV:N/AC:L/Au:N/C:N/I:P/A:P - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
libraries/auth/swekey/swekey.auth.lib.php in phpMyAdmin 3.x before 3.3.10.3 and 3.4.x before 3.4.3.2 does not properly manage sessions associated with Swekey authentication, which allows remote attackers to modify the SESSION superglobal array, other superglobal arrays, and certain swekey.auth.lib.php local variables via a crafted query string, a related issue to CVE-2011-2505.
- Record
CVE-2011-2719- Updated
- 2026-11-02
EUVDEUVD-2011-2697 No score
libraries/auth/swekey/swekey.auth.lib.php in phpMyAdmin 3.x before 3.3.10.3 and 3.4.x before 3.4.3.2 does not properly manage sessions associated with Swekey authentication, which allows remote attackers to modify the SESSION superglobal array, other superglobal arrays, and certain swekey.auth.lib.php local variables via a crafted query string, a related issue to CVE-2011-2505.
- Record
EUVD-2011-2697- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-fmmw-6q24-3wqx No score
libraries/auth/swekey/swekey.auth.lib.php in phpMyAdmin 3.x before 3.3.10.3 and 3.4.x before 3.4...
libraries/auth/swekey/swekey.auth.lib.php in phpMyAdmin 3.x before 3.3.10.3 and 3.4.x before 3.4.3.2 does not properly manage sessions associated with Swekey authentication, which allows remote attackers to modify the SESSION superglobal array, other superglobal arrays, and certain swekey.auth.lib.php local variables via a crafted query string, a related issue to CVE-2011-2505.
- Record
GHSA-fmmw-6q24-3wqx- Weakness
- CWE-20
- Updated
- 2026-11-02
OSV No score
libraries/auth/swekey/swekey.auth.lib.php in phpMyAdmin 3.x before 3.3.10.3 and 3.4.x before 3.4.3.2 does not properly manage sessions associated with Swekey authentication, which allows remote attackers to modify the SESSION superglobal array, other superglobal arrays, and certain swekey.auth.lib.php local variables via a crafted query string, a related issue to CVE-2011-2505.
- Record
CVE-2011-2719- Updated
- 2026-11-02
OSVDEBIAN-CVE-2011-2719 No score
libraries/auth/swekey/swekey.auth.lib.php in phpMyAdmin 3.x before 3.3.10.3 and 3.4.x before 3.4.3.2 does not properly manage sessions associated with Swekey authentication, which allows remote attackers to modify the SESSION superglobal array, other superglobal arrays, and certain swekey.auth.lib.php local variables via a crafted query string, a related issue to CVE-2011-2505.
- Record
DEBIAN-CVE-2011-2719- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
phpmyadminDebian:12 |
before 4:3.4.3.2-1 | 4:3.4.3.2-1 |
phpmyadminDebian:13 |
before 4:3.4.3.2-1 | 4:3.4.3.2-1 |
phpmyadminDebian:14 |
before 4:3.4.3.2-1 | 4:3.4.3.2-1 |
phpmyadminDebian:6.0 |
before 4:3.3.7-6, plus listed versions 4:3.3.7-34:3.3.7-5 |
4:3.3.7-6 |
phpmyadminDebian:5.0 |
before 4:2.11.8.1-5+lenny9, plus listed versions 4:2.11.8.1-54:2.11.8.1-5+lenny14:2.11.8.1-5+lenny34:2.11.8.1-5+lenny44:2.11.8.1-5+lenny54:2.11.8.1-5+lenny64:2.11.8.1-5+lenny74:2.11.8.1-5+lenny8 |
4:2.11.8.1-5+lenny9 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2011-2719 is a medium vulnerability (CVSS 6.4) in Phpmyadmin, published July 26, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.43%, the 84th percentile. Fixed in phpmyadmin 4:3.4.3.2-1.
References
phpmyadmin.git.sourceforge.net/git/gitweb.cgi?p=phpmyadmin/phpmyadmin%3Ba=commit%3Bh=e7bb42c002885c2aca7aba4d431b8c63ae4de9b7
securityfocus.com/archive/1/518967/100/0/threaded
seclists.org/fulldisclosure/2011/Jul/300
securityfocus.com/archive/1/519155/100/0/threaded
secunia.com/advisories/45515
bugzilla.redhat.com/show_bug.cgi?id=725384
Show 20 moreShow less
secunia.com/advisories/45365
securityfocus.com/bid/48874
mandriva.com/security/advisories?name=MDVSA-2011:124
openwall.com/lists/oss-security/2011/07/26/10
osvdb.org/74112
phpmyadmin.git.sourceforge.net/git/gitweb.cgi?p=phpmyadmin/phpmyadmin%3Ba=commit%3Bh=571cdc6ff4bf375871b594f4e06f8ad3159d1754
phpmyadmin.net/home_page/security/PMASA-2011-12.php
debian.org/security/2011/dsa-2286
securityreason.com/securityalert/8322
lists.fedoraproject.org/pipermail/package-announce/2011-August/063410.html
lists.fedoraproject.org/pipermail/package-announce/2011-August/063418.html
secunia.com/advisories/45315
openwall.com/lists/oss-security/2011/07/25/4
exchange.xforce.ibmcloud.com/vulnerabilities/68769
xxor.se/advisories/phpMyAdmin_3.x_Conditional_Session_Manipulation.txt
nvd.nist.gov/vuln/detail/CVE-2011-2719
phpmyadmin.git.sourceforge.net/git/gitweb.cgi?p=phpmyadmin/phpmyadmin;a=commit;h=571cdc6ff4bf375871b594f4e06f8ad3159d1754
phpmyadmin.git.sourceforge.net/git/gitweb.cgi?p=phpmyadmin/phpmyadmin;a=commit;h=e7bb42c002885c2aca7aba4d431b8c63ae4de9b7
github.com/advisories/GHSA-fmmw-6q24-3wqx
security-tracker.debian.org/tracker/CVE-2011-2719