CVE-2011-3358
Multiple cross-site scripting (XSS) vulnerabilities in MantisBT before 1.2.8 allow remote...
Multiple cross-site scripting (XSS) vulnerabilities in MantisBT before 1.2.8 allow remote attackers to inject arbitrary web script or HTML via the (1) os, (2) os_build, or (3) platform parameter to (a) bug_report_page.php or (b) bug_update_advanced_page.php, related to use of the Projax library.
Exploit likelihood
What each source reports
NVD Score used
4.3
Multiple cross-site scripting (XSS) vulnerabilities in MantisBT before 1.2.8 allow remote attackers to inject arbitrary web script or HTML via the (1) os, (2) os_build, or (3) platform parameter to (a) bug_report_page.php or (b) bug_update_advanced_page.php, related to use of the Projax library.
- Record
CVE-2011-3358- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Multiple cross-site scripting (XSS) vulnerabilities in MantisBT before 1.2.8 allow remote attackers to inject arbitrary web script or HTML via the (1) os, (2) os_build, or (3) platform parameter to (a) bug_report_page.php or (b) bug_update_advanced_page.php, related to use of the Projax library.
- Record
CVE-2011-3358- Updated
- 2026-11-02
EUVDEUVD-2011-3322 No score
Multiple cross-site scripting (XSS) vulnerabilities in MantisBT before 1.2.8 allow remote attackers to inject arbitrary web script or HTML via the (1) os, (2) os_build, or (3) platform parameter to (a) bug_report_page.php or (b) bug_update_advanced_page.php, related to use of the Projax library.
- Record
EUVD-2011-3322- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-hrpm-3rq3-r229 No score
Multiple cross-site scripting (XSS) vulnerabilities in MantisBT before 1.2.8 allow remote...
Multiple cross-site scripting (XSS) vulnerabilities in MantisBT before 1.2.8 allow remote attackers to inject arbitrary web script or HTML via the (1) os, (2) os_build, or (3) platform parameter to (a) bug_report_page.php or (b) bug_update_advanced_page.php, related to use of the Projax library.
- Record
GHSA-hrpm-3rq3-r229- Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mantisDebian:6.0 |
before 1.1.8+dfsg-10squeeze1, plus listed versions 1.1.8+dfsg-10 |
1.1.8+dfsg-10squeeze1 |
mantisDebian:5.0 |
before 1.1.6+dfsg-2lenny6, plus listed versions 1.1.6+dfsg-21.1.6+dfsg-2lenny11.1.6+dfsg-2lenny21.1.6+dfsg-2lenny31.1.6+dfsg-2lenny4 |
1.1.6+dfsg-2lenny6 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2011-3358 is a medium vulnerability (CVSS 4.3) in Mantisbt, published September 12, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.83%, the 78th percentile. Fixed in mantis 1.1.8+dfsg-10squeeze1.
References
securityreason.com/securityalert/8392
debian.org/security/2011/dsa-2308
openwall.com/lists/oss-security/2011/09/04/1
security.gentoo.org/glsa/glsa-201211-01.xml
exchange.xforce.ibmcloud.com/vulnerabilities/69589
htbridge.ch/advisory/multiple_vulnerabilities_in_mantisbt.html
Show 12 moreShow less
secunia.com/advisories/45961
bugs.debian.org/cgi-bin/bugreport.cgi?bug=640297
bugzilla.redhat.com/show_bug.cgi?id=735514
securityfocus.com/bid/49448
secunia.com/advisories/51199
openwall.com/lists/oss-security/2011/09/09/9
lists.debian.org/debian-security-tracker/2011/09/msg00012.html
lists.fedoraproject.org/pipermail/package-announce/2011-September/066061.html
github.com/mantisbt/mantisbt/commit/0a636b37d3425aea7b781e7f25eaeb164ac54a3d
securityfocus.com/archive/1/519547/100/0/threaded
nvd.nist.gov/vuln/detail/CVE-2011-3358
github.com/advisories/GHSA-hrpm-3rq3-r229