Every CVE Search/ Get API key

CVE-2011-4328

plugin/npapi/plugin.cpp in Gnash before 0.8.10 uses weak permissions (world readable) for cookie...

5.0 MediumFix available

plugin/npapi/plugin.cpp in Gnash before 0.8.10 uses weak permissions (world readable) for cookie files with predictable names in /tmp, which allows local users to obtain sensitive information.

Exploit likelihood

2.11%Up 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

plugin/npapi/plugin.cpp in Gnash before 0.8.10 uses weak permissions (world readable) for cookie files with predictable names in /tmp, which allows local users to obtain sensitive information.

Record
CVE-2011-4328
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

plugin/npapi/plugin.cpp in Gnash before 0.8.10 uses weak permissions (world readable) for cookie files with predictable names in /tmp, which allows local users to obtain sensitive information.

Record
CVE-2011-4328
Updated
2026-11-02
EUVDEUVD-2011-4260 No score

plugin/npapi/plugin.cpp in Gnash before 0.8.10 uses weak permissions (world readable) for cookie files with predictable names in /tmp, which allows local users to obtain sensitive information.

Record
EUVD-2011-4260
Updated
2026-11-03
GitHub AdvisoriesGHSA-43gq-7wp4-9vh5 No score

plugin/npapi/plugin.cpp in Gnash before 0.8.10 uses weak permissions (world readable) for cookie...

plugin/npapi/plugin.cpp in Gnash before 0.8.10 uses weak permissions (world readable) for cookie files with predictable names in /tmp, which allows local users to obtain sensitive information.

Record
GHSA-43gq-7wp4-9vh5
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gnash
Debian:6.0
before 0.8.8-5+squeeze1, plus listed versions
0.8.8-50.8.8-5squeeze10.8.8-5squeeze2
0.8.8-5+squeeze1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-4328 is a medium vulnerability (CVSS 5.0) in Gnu Gnash, published March 19, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.11%, the 81st percentile. Fixed in gnash 0.8.8-5+squeeze1.

References

Show 9 moreShow less
MoveEnter Open