Every CVE Search/ Get API key

CVE-2012-0825

Drupal 6.x before 6.23 and 7.x before 7.11 does not verify that Attribute Exchange (AX)...

6.8 MediumFix available

Drupal 6.x before 6.23 and 7.x before 7.11 does not verify that Attribute Exchange (AX) information is signed, which allows remote attackers to modify potentially sensitive AX information without detection via a man-in-the-middle (MITM) attack.

Exploit likelihood

1.98%Up 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

Drupal 6.x before 6.23 and 7.x before 7.11 does not verify that Attribute Exchange (AX) information is signed, which allows remote attackers to modify potentially sensitive AX information without detection via a man-in-the-middle (MITM) attack.

Record
CVE-2012-0825
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-200
Updated
2026-11-02
CVE List No score

Drupal 6.x before 6.23 and 7.x before 7.11 does not verify that Attribute Exchange (AX) information is signed, which allows remote attackers to modify potentially sensitive AX information without detection via a man-in-the-middle (MITM) attack.

Record
CVE-2012-0825
Updated
2026-11-02
EUVDEUVD-2012-0851 No score

Drupal 6.x before 6.23 and 7.x before 7.11 does not verify that Attribute Exchange (AX) information is signed, which allows remote attackers to modify potentially sensitive AX information without detection via a man-in-the-middle (MITM) attack.

Record
EUVD-2012-0851
Updated
2026-11-03
GitHub AdvisoriesGHSA-9f2c-79x6-jgvf No score

Drupal 6.x before 6.23 and 7.x before 7.11 does not verify that Attribute Exchange (AX)...

Drupal 6.x before 6.23 and 7.x before 7.11 does not verify that Attribute Exchange (AX) information is signed, which allows remote attackers to modify potentially sensitive AX information without detection via a man-in-the-middle (MITM) attack.

Record
GHSA-9f2c-79x6-jgvf
Weakness
CWE-200
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
drupal6
Debian:6.0
before 6.28-1, plus listed versions
6.18-16.18-1squeeze16.20-16.20-1~bpo50+16.20-1~bpo60+1
Show 6 moreShow less
6.20-26.22-16.22-1~bpo60+16.26-16.26-1.16.26-1~bpo60+1
6.28-1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-0825 is a medium vulnerability (CVSS 6.8) in Drupal, published October 11, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.98%, the 80th percentile. Fixed in drupal6 6.28-1.

References

MoveEnter Open