Every CVE Search/ Get API key

CVE-2012-1663

Double free vulnerability in libgnutls in GnuTLS before 3.0.14 allows remote attackers to cause a...

7.5 HighPublic exploitFix available

Double free vulnerability in libgnutls in GnuTLS before 3.0.14 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted certificate list.

Exploit likelihood

4.89%Down 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Double free vulnerability in libgnutls in GnuTLS before 3.0.14 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted certificate list.

Record
CVE-2012-1663
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-399
Updated
2026-11-02
CVE List No score

Double free vulnerability in libgnutls in GnuTLS before 3.0.14 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted certificate list.

Record
CVE-2012-1663
Updated
2026-11-02
EUVDEUVD-2012-1673 No score

Double free vulnerability in libgnutls in GnuTLS before 3.0.14 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted certificate list.

Record
EUVD-2012-1673
Updated
2026-11-03
GitHub AdvisoriesGHSA-jjqc-5mxx-88h5 No score

Double free vulnerability in libgnutls in GnuTLS before 3.0.14 allows remote attackers to cause a...

Double free vulnerability in libgnutls in GnuTLS before 3.0.14 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted certificate list.

Record
GHSA-jjqc-5mxx-88h5
Updated
2026-11-02
OSV No score

Double free vulnerability in libgnutls in GnuTLS before 3.0.14 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted certificate list.

Record
CVE-2012-1663
Updated
2026-11-02
OSVDEBIAN-CVE-2012-1663 No score

Double free vulnerability in libgnutls in GnuTLS before 3.0.14 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted certificate list.

Record
DEBIAN-CVE-2012-1663
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gnutls28
Debian:12
before 3.0.14-1
3.0.14-1
gnutls28
Debian:13
before 3.0.14-1
3.0.14-1
gnutls28
Debian:14
before 3.0.14-1
3.0.14-1

Public exploits

Links only. Every CVE stores no exploit code.

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-1663 is a high vulnerability (CVSS 7.5) in Gnu Gnutls, published March 13, 2012. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 4.89%, the 92nd percentile. Fixed in gnutls28 3.0.14-1.

References

MoveEnter Open