CVE-2012-2149
The WPXContentListener::_closeTableRow function in WPXContentListener.cpp in libwpd 0.8.8, as...
The WPXContentListener::_closeTableRow function in WPXContentListener.cpp in libwpd 0.8.8, as used by OpenOffice.org (OOo) before 3.4, allows remote attackers to execute arbitrary code via a crafted Wordperfect .WPD document that causes a negative array index to be used. NOTE: some sources report this issue as an integer overflow.
Exploit likelihood
What each source reports
NVD Score used
7.5
The WPXContentListener::_closeTableRow function in WPXContentListener.cpp in libwpd 0.8.8, as used by OpenOffice.org (OOo) before 3.4, allows remote attackers to execute arbitrary code via a crafted Wordperfect .WPD document that causes a negative array index to be used. NOTE: some sources report this issue as an integer overflow.
- Record
CVE-2012-2149- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-189
- Updated
- 2026-11-02
CVE List No score
The WPXContentListener::_closeTableRow function in WPXContentListener.cpp in libwpd 0.8.8, as used by OpenOffice.org (OOo) before 3.4, allows remote attackers to execute arbitrary code via a crafted Wordperfect .WPD document that causes a negative array index to be used. NOTE: some sources report this issue as an integer overflow.
- Record
CVE-2012-2149- Updated
- 2026-11-02
EUVDEUVD-2012-2144 No score
The WPXContentListener::_closeTableRow function in WPXContentListener.cpp in libwpd 0.8.8, as used by OpenOffice.org (OOo) before 3.4, allows remote attackers to execute arbitrary code via a crafted Wordperfect .WPD document that causes a negative array index to be used. NOTE: some sources report this issue as an integer overflow.
- Record
EUVD-2012-2144- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-q242-fx58-pm2p No score
The WPXContentListener::_closeTableRow function in WPXContentListener.cpp in libwpd 0.8.8, as...
The WPXContentListener::_closeTableRow function in WPXContentListener.cpp in libwpd 0.8.8, as used by OpenOffice.org (OOo) before 3.4, allows remote attackers to execute arbitrary code via a crafted Wordperfect .WPD document that causes a negative array index to be used. NOTE: some sources report this issue as an integer overflow.
- Record
GHSA-q242-fx58-pm2p- Updated
- 2026-11-02
OSV No score
The WPXContentListener::_closeTableRow function in WPXContentListener.cpp in libwpd 0.8.8, as used by OpenOffice.org (OOo) before 3.4, allows remote attackers to execute arbitrary code via a crafted Wordperfect .WPD document that causes a negative array index to be used. NOTE: some sources report this issue as an integer overflow.
- Record
CVE-2012-2149- Updated
- 2026-11-02
OSVDEBIAN-CVE-2012-2149 No score
The WPXContentListener::_closeTableRow function in WPXContentListener.cpp in libwpd 0.8.8, as used by OpenOffice.org (OOo) before 3.4, allows remote attackers to execute arbitrary code via a crafted Wordperfect .WPD document that causes a negative array index to be used. NOTE: some sources report this issue as an integer overflow.
- Record
DEBIAN-CVE-2012-2149- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libwpdDebian:12 |
before 0.8.14-1 | 0.8.14-1 |
libwpdDebian:13 |
before 0.8.14-1 | 0.8.14-1 |
libwpdDebian:14 |
before 0.8.14-1 | 0.8.14-1 |
libwpdRed Hat:enterprise_linux:5::client |
before 0:0.8.7-3.1.el5_8 | 0:0.8.7-3.1.el5_8 |
libwpd-debuginfoRed Hat:enterprise_linux:5::client |
before 0:0.8.7-3.1.el5_8 | 0:0.8.7-3.1.el5_8 |
libwpd-toolsRed Hat:enterprise_linux:5::client |
before 0:0.8.7-3.1.el5_8 | 0:0.8.7-3.1.el5_8 |
libwpdRed Hat:enterprise_linux:5::client_workstation |
before 0:0.8.7-3.1.el5_8 | 0:0.8.7-3.1.el5_8 |
libwpd-debuginfoRed Hat:enterprise_linux:5::client_workstation |
before 0:0.8.7-3.1.el5_8 | 0:0.8.7-3.1.el5_8 |
libwpd-develRed Hat:enterprise_linux:5::client_workstation |
before 0:0.8.7-3.1.el5_8 | 0:0.8.7-3.1.el5_8 |
libwpdRed Hat:rhel_productivity:5 |
before 0:0.8.7-3.1.el5_8 | 0:0.8.7-3.1.el5_8 |
libwpd-debuginfoRed Hat:rhel_productivity:5 |
before 0:0.8.7-3.1.el5_8 | 0:0.8.7-3.1.el5_8 |
libwpd-develRed Hat:rhel_productivity:5 |
before 0:0.8.7-3.1.el5_8 | 0:0.8.7-3.1.el5_8 |
libwpd-toolsRed Hat:rhel_productivity:5 |
before 0:0.8.7-3.1.el5_8 | 0:0.8.7-3.1.el5_8 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2012-2149 is a high vulnerability (CVSS 7.5) in Apache Openoffice.org, published June 21, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 13.7%, the 96th percentile. Fixed in libwpd 0.8.14-1.
References
secunia.com/advisories/60799
gentoo.org/security/en/glsa/glsa-201408-19.xml
securitytracker.com/id?1027069
rhn.redhat.com/errata/RHSA-2012-1043.html
sec-consult.com/files/20120518-0_openoffice_memory_overwrite.txt
archives.neohapsis.com/archives/bugtraq/2012-05/0090.html
Show 13 moreShow less
securityfocus.com/bid/53570
openoffice.org/security/cves/CVE-2012-2149.html
packetstormsecurity.org/files/112862/libwpd-WPXContentListener-_closeTableRow-Memory-Overwrite.html
secunia.com/advisories/46992
nvd.nist.gov/vuln/detail/CVE-2012-2149
github.com/advisories/GHSA-q242-fx58-pm2p
security-tracker.debian.org/tracker/CVE-2012-2149
access.redhat.com/errata/RHSA-2012:1043
access.redhat.com/security/updates/classification
bugzilla.redhat.com/show_bug.cgi?id=822207
security.access.redhat.com/data/csaf/v2/advisories/2012/rhsa-2012_1043.json
access.redhat.com/security/cve/CVE-2012-2149
cve.org/CVERecord?id=CVE-2012-2149