Every CVE Search/ Get API key

CVE-2012-2311

sapi/cgi/cgi_main.c in PHP before 5.3.13 and 5.4.x before 5.4.3, when configured as a CGI script ...

7.5 HighPublic exploit

sapi/cgi/cgi_main.c in PHP before 5.3.13 and 5.4.x before 5.4.3, when configured as a CGI script (aka php-cgi), does not properly handle query strings that contain a %3D sequence but no = (equals sign) character, which allows remote attackers to execute arbitrary code by placing command-line options in the query string, related to lack of skipping a certain php_getopt for the 'd' case. NOTE: this vulnerability exists because of an incomplete fix for CVE-2012-1823.

Exploit likelihood

69.3%Up 5.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

sapi/cgi/cgi_main.c in PHP before 5.3.13 and 5.4.x before 5.4.3, when configured as a CGI script (aka php-cgi), does not properly handle query strings that contain a %3D sequence but no = (equals sign) character, which allows remote attackers to execute arbitrary code by placing command-line options in the query string, related to lack of skipping a certain php_getopt for the 'd' case. NOTE: this vulnerability exists because of an incomplete fix for CVE-2012-1823.

Record
CVE-2012-2311
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-89
Updated
2026-11-02
CVE List No score

sapi/cgi/cgi_main.c in PHP before 5.3.13 and 5.4.x before 5.4.3, when configured as a CGI script (aka php-cgi), does not properly handle query strings that contain a %3D sequence but no = (equals sign) character, which allows remote attackers to execute arbitrary code by placing command-line options in the query string, related to lack of skipping a certain php_getopt for the 'd' case. NOTE: this vulnerability exists because of an incomplete fix for CVE-2012-1823.

Record
CVE-2012-2311
Updated
2026-11-02
EUVDEUVD-2012-2304 No score

sapi/cgi/cgi_main.c in PHP before 5.3.13 and 5.4.x before 5.4.3, when configured as a CGI script (aka php-cgi), does not properly handle query strings that contain a %3D sequence but no = (equals sign) character, which allows remote attackers to execute arbitrary code by placing command-line options in the query string, related to lack of skipping a certain php_getopt for the 'd' case. NOTE: this vulnerability exists because of an incomplete fix for CVE-2012-1823.

Record
EUVD-2012-2304
Updated
2026-11-03
GitHub AdvisoriesGHSA-9c8w-rvgj-w489 No score

sapi/cgi/cgi_main.c in PHP before 5.3.13 and 5.4.x before 5.4.3, when configured as a CGI script ...

sapi/cgi/cgi_main.c in PHP before 5.3.13 and 5.4.x before 5.4.3, when configured as a CGI script (aka php-cgi), does not properly handle query strings that contain a %3D sequence but no = (equals sign) character, which allows remote attackers to execute arbitrary code by placing command-line options in the query string, related to lack of skipping a certain php_getopt for the 'd' case. NOTE: this vulnerability exists because of an incomplete fix for CVE-2012-1823.

Record
GHSA-9c8w-rvgj-w489
Weakness
CWE-89
Updated
2026-11-02
OSVBELL-CVE-2012-2311 7.5

CVE-2012-2311 does not affect BellSoft software

Record
BELL-CVE-2012-2311
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
OSVopenSUSE-SU-2024:10290-1 No score

apache2-mod_php7-7.0.14-1.4 on GA media

These are all security issues fixed in the apache2-mod_php7-7.0.14-1.4 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10290-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:10344-1 No score

apache2-mod_php5-5.6.28-1.1 on GA media

These are all security issues fixed in the apache2-mod_php5-5.6.28-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10344-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
php5
Debian:6.0
From an advisory covering 3 CVEs
before 5.3.3-7+squeeze9, plus listed versions
5.3.3-75.3.3-7+squeeze15.3.3-7+squeeze25.3.3-7+squeeze35.3.3-7+squeeze55.3.3-7+squeeze65.3.3-7+squeeze75.3.3-7+squeeze8
5.3.3-7+squeeze9
php7
openSUSE:Tumbleweed
From an advisory covering 70 CVEs
before 7.0.14-1.4
7.0.14-1.4
php5
openSUSE:Tumbleweed
From an advisory covering 71 CVEs
before 5.6.28-1.1
5.6.28-1.1

Public exploits

Links only. Every CVE stores no exploit code.

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-2311 is a high vulnerability (CVSS 7.5) in Php, published May 9, 2012. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 69.3%, the 99th percentile. No source names a fixed version.

References

Show 85 moreShow less
MoveEnter Open