Every CVE Search/ Get API key

CVE-2012-2335

php-wrapper.fcgi does not properly handle command-line arguments, which allows remote attackers...

7.5 High

php-wrapper.fcgi does not properly handle command-line arguments, which allows remote attackers to bypass a protection mechanism in PHP 5.3.12 and 5.4.2 and execute arbitrary code by leveraging improper interaction between the PHP sapi/cgi/cgi_main.c component and a query string beginning with a +- sequence.

Exploit likelihood

33.7%Up 22.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

php-wrapper.fcgi does not properly handle command-line arguments, which allows remote attackers to bypass a protection mechanism in PHP 5.3.12 and 5.4.2 and execute arbitrary code by leveraging improper interaction between the PHP sapi/cgi/cgi_main.c component and a query string beginning with a +- sequence.

Record
CVE-2012-2335
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

php-wrapper.fcgi does not properly handle command-line arguments, which allows remote attackers to bypass a protection mechanism in PHP 5.3.12 and 5.4.2 and execute arbitrary code by leveraging improper interaction between the PHP sapi/cgi/cgi_main.c component and a query string beginning with a +- sequence.

Record
CVE-2012-2335
Updated
2026-11-02
EUVDEUVD-2012-2328 No score

php-wrapper.fcgi does not properly handle command-line arguments, which allows remote attackers to bypass a protection mechanism in PHP 5.3.12 and 5.4.2 and execute arbitrary code by leveraging improper interaction between the PHP sapi/cgi/cgi_main.c component and a query string beginning with a +- sequence.

Record
EUVD-2012-2328
Updated
2026-11-03
GitHub AdvisoriesGHSA-ppq5-vhcq-mxw2 No score

php-wrapper.fcgi does not properly handle command-line arguments, which allows remote attackers...

php-wrapper.fcgi does not properly handle command-line arguments, which allows remote attackers to bypass a protection mechanism in PHP 5.3.12 and 5.4.2 and execute arbitrary code by leveraging improper interaction between the PHP sapi/cgi/cgi_main.c component and a query string beginning with a +- sequence.

Record
GHSA-ppq5-vhcq-mxw2
Updated
2026-11-02
OSVopenSUSE-SU-2024:10290-1 No score

apache2-mod_php7-7.0.14-1.4 on GA media

These are all security issues fixed in the apache2-mod_php7-7.0.14-1.4 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10290-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:10344-1 No score

apache2-mod_php5-5.6.28-1.1 on GA media

These are all security issues fixed in the apache2-mod_php5-5.6.28-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10344-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
php7
openSUSE:Tumbleweed
From an advisory covering 70 CVEs
before 7.0.14-1.4
7.0.14-1.4
php5
openSUSE:Tumbleweed
From an advisory covering 71 CVEs
before 5.6.28-1.1
5.6.28-1.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-2335 is a high vulnerability (CVSS 7.5) in Php, published May 11, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 33.7%, the 98th percentile. No source names a fixed version.

References

Show 78 moreShow less
MoveEnter Open