Every CVE Search/ Get API key

CVE-2012-3435

SQL injection vulnerability in frontends/php/popup_bitem.php in Zabbix 1.8.15rc1 and earlier, and...

7.5 HighPublic exploitFix available

SQL injection vulnerability in frontends/php/popup_bitem.php in Zabbix 1.8.15rc1 and earlier, and 2.x before 2.0.2rc1, allows remote attackers to execute arbitrary SQL commands via the itemid parameter.

Exploit likelihood

3.58%Down 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

SQL injection vulnerability in frontends/php/popup_bitem.php in Zabbix 1.8.15rc1 and earlier, and 2.x before 2.0.2rc1, allows remote attackers to execute arbitrary SQL commands via the itemid parameter.

Record
CVE-2012-3435
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-89
Updated
2026-11-02
CVE List No score

SQL injection vulnerability in frontends/php/popup_bitem.php in Zabbix 1.8.15rc1 and earlier, and 2.x before 2.0.2rc1, allows remote attackers to execute arbitrary SQL commands via the itemid parameter.

Record
CVE-2012-3435
Updated
2026-11-02
EUVDEUVD-2012-3402 No score

SQL injection vulnerability in frontends/php/popup_bitem.php in Zabbix 1.8.15rc1 and earlier, and 2.x before 2.0.2rc1, allows remote attackers to execute arbitrary SQL commands via the itemid parameter.

Record
EUVD-2012-3402
Updated
2026-11-03
GitHub AdvisoriesGHSA-w8xh-986v-xwgh No score

SQL injection vulnerability in frontends/php/popup_bitem.php in Zabbix 1.8.15rc1 and earlier, and...

SQL injection vulnerability in frontends/php/popup_bitem.php in Zabbix 1.8.15rc1 and earlier, and 2.x before 2.0.2rc1, allows remote attackers to execute arbitrary SQL commands via the itemid parameter.

Record
GHSA-w8xh-986v-xwgh
Weakness
CWE-89
Updated
2026-11-02
OSV No score

SQL injection vulnerability in frontends/php/popup_bitem.php in Zabbix 1.8.15rc1 and earlier, and 2.x before 2.0.2rc1, allows remote attackers to execute arbitrary SQL commands via the itemid parameter.

Record
CVE-2012-3435
Updated
2026-11-02
OSVDEBIAN-CVE-2012-3435 No score

SQL injection vulnerability in frontends/php/popup_bitem.php in Zabbix 1.8.15rc1 and earlier, and 2.x before 2.0.2rc1, allows remote attackers to execute arbitrary SQL commands via the itemid parameter.

Record
DEBIAN-CVE-2012-3435
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
zabbix
Debian:12
before 1:2.0.2+dfsg-1
1:2.0.2+dfsg-1
zabbix
Debian:13
before 1:2.0.2+dfsg-1
1:2.0.2+dfsg-1
zabbix
Debian:14
before 1:2.0.2+dfsg-1
1:2.0.2+dfsg-1
zabbix
Debian:6.0
before 1:1.8.2-1squeeze4, plus listed versions
1:1.8.2-1squeeze2
1:1.8.2-1squeeze4

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBZabbix 2.0.1 - Session Extractor2012-07-24

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-3435 is a high vulnerability (CVSS 7.5) in Zabbix, published August 15, 2012. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 3.58%, the 89th percentile. Fixed in zabbix 1:2.0.2+dfsg-1.

References

Show 8 moreShow less
MoveEnter Open