Every CVE Search/ Get API key

CVE-2012-3864

Puppet before 2.6.17 and 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, allows remote...

4.0 MediumFix available

Puppet before 2.6.17 and 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, allows remote authenticated users to read arbitrary files on the puppet master server by leveraging an arbitrary user's certificate and private key in a GET request.

Exploit likelihood

1.91%Up 0.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.0

Puppet before 2.6.17 and 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, allows remote authenticated users to read arbitrary files on the puppet master server by leveraging an arbitrary user's certificate and private key in a GET request.

Record
CVE-2012-3864
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:P/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
CVE List No score

Puppet before 2.6.17 and 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, allows remote authenticated users to read arbitrary files on the puppet master server by leveraging an arbitrary user's certificate and private key in a GET request.

Record
CVE-2012-3864
Updated
2026-11-02
EUVDEUVD-2012-3811 No score

Puppet before 2.6.17 and 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, allows remote authenticated users to read arbitrary files on the puppet master server by leveraging an arbitrary user's certificate and private key in a GET request.

Record
EUVD-2012-3811
Updated
2026-11-03
GitHub AdvisoriesGHSA-8xhg-x93x-j983 No score

Puppet before 2.6.17 and 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, allows remote...

Puppet before 2.6.17 and 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, allows remote authenticated users to read arbitrary files on the puppet master server by leveraging an arbitrary user's certificate and private key in a GET request.

Record
GHSA-8xhg-x93x-j983
Weakness
CWE-200
Updated
2026-11-02
OSV No score

Puppet before 2.6.17 and 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, allows remote authenticated users to read arbitrary files on the puppet master server by leveraging an arbitrary user's certificate and private key in a GET request.

Record
CVE-2012-3864
Updated
2026-11-02
OSVDEBIAN-CVE-2012-3864 No score

Puppet before 2.6.17 and 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, allows remote authenticated users to read arbitrary files on the puppet master server by leveraging an arbitrary user's certificate and private key in a GET request.

Record
DEBIAN-CVE-2012-3864
Updated
2026-11-02
OSVopenSUSE-SU-2024:10581-1 No score

ruby2.2-rubygem-puppet-3.8.7-2.2 on GA media

These are all security issues fixed in the ruby2.2-rubygem-puppet-3.8.7-2.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10581-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
puppet
Debian:11
before 2.7.18-1
2.7.18-1
puppet
Debian:6.0
before 2.6.2-5+squeeze6, plus listed versions
2.6.2-42.6.2-52.6.2-5+squeeze12.6.2-5+squeeze32.6.2-5+squeeze42.6.2-5+squeeze5
2.6.2-5+squeeze6

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-3864 is a medium vulnerability (CVSS 4.0) in Puppet, published July 12, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.91%, the 79th percentile. Fixed in puppet 2.7.18-1.

References

Show 17 moreShow less
MoveEnter Open