Every CVE Search/ Get API key

CVE-2012-4382

MediaWiki before 1.18.5, and 1.19.x before 1.19.2 does not properly protect user block metadata,...

4.9 MediumFix available

MediaWiki before 1.18.5, and 1.19.x before 1.19.2 does not properly protect user block metadata, which allows remote administrators to read a user block reason via a reblock attempt.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
High
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

1.20%Up 0.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.9

MediaWiki before 1.18.5, and 1.19.x before 1.19.2 does not properly protect user block metadata, which allows remote administrators to read a user block reason via a reblock attempt.

Record
CVE-2012-4382
CVSS 3.0
4.9 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:P/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
CVE List No score

MediaWiki before 1.18.5, and 1.19.x before 1.19.2 does not properly protect user block metadata, which allows remote administrators to read a user block reason via a reblock attempt.

Record
CVE-2012-4382
Updated
2026-11-02
EUVDEUVD-2012-4325 No score

MediaWiki before 1.18.5, and 1.19.x before 1.19.2 does not properly protect user block metadata, which allows remote administrators to read a user block reason via a reblock attempt.

Record
EUVD-2012-4325
Updated
2026-11-03
GitHub AdvisoriesGHSA-qxg6-q47j-rhmf 4.9

MediaWiki before 1.18.5, and 1.19.x before 1.19.2 does not properly protect user block metadata,...

MediaWiki before 1.18.5, and 1.19.x before 1.19.2 does not properly protect user block metadata, which allows remote administrators to read a user block reason via a reblock attempt.

Record
GHSA-qxg6-q47j-rhmf
CVSS 3.0
4.9 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
OSV 4.9

MediaWiki before 1.18.5, and 1.19.x before 1.19.2 does not properly protect user block metadata, which allows remote administrators to read a user block reason via a reblock attempt.

Record
CVE-2012-4382
CVSS 3.0
4.9 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2012-4382 4.9

MediaWiki before 1.18.5, and 1.19.x before 1.19.2 does not properly protect user block metadata, which allows remote administrators to read a user block reason via a reblock attempt.

Record
DEBIAN-CVE-2012-4382
CVSS 3.0
4.9 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2012-4382 4.9

MediaWiki before 1.18.5, and 1.19.x before 1.19.2 does not properly protect user block metadata, which allows remote administrators to read a user block reason via a reblock attempt.

Record
UBUNTU-CVE-2012-4382
CVSS 3.0
4.9 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mediawiki
Debian:12
before 1:1.19.2-1
1:1.19.2-1
mediawiki
Debian:13
before 1:1.19.2-1
1:1.19.2-1
mediawiki
Debian:14
before 1:1.19.2-1
1:1.19.2-1

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-4382 is a medium vulnerability (CVSS 4.9) in Mediawiki, published October 19, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.20%, the 68th percentile. Fixed in mediawiki 1:1.19.2-1.

References

Show 4 moreShow less
MoveEnter Open