Every CVE Search/ Get API key

CVE-2012-4422

wp-admin/plugins.php in WordPress before 3.4.2, when the multisite feature is enabled, does not...

3.5 LowFix available

wp-admin/plugins.php in WordPress before 3.4.2, when the multisite feature is enabled, does not check for network-administrator privileges before performing a network-wide activation of an installed plugin, which might allow remote authenticated users to make unintended plugin changes by leveraging the Administrator role.

Exploit likelihood

1.68%Up 0.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 3.5

wp-admin/plugins.php in WordPress before 3.4.2, when the multisite feature is enabled, does not check for network-administrator privileges before performing a network-wide activation of an installed plugin, which might allow remote authenticated users to make unintended plugin changes by leveraging the Administrator role.

Record
CVE-2012-4422
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

wp-admin/plugins.php in WordPress before 3.4.2, when the multisite feature is enabled, does not check for network-administrator privileges before performing a network-wide activation of an installed plugin, which might allow remote authenticated users to make unintended plugin changes by leveraging the Administrator role.

Record
CVE-2012-4422
Updated
2026-11-02
EUVDEUVD-2012-4357 No score

wp-admin/plugins.php in WordPress before 3.4.2, when the multisite feature is enabled, does not check for network-administrator privileges before performing a network-wide activation of an installed plugin, which might allow remote authenticated users to make unintended plugin changes by leveraging the Administrator role.

Record
EUVD-2012-4357
Updated
2026-11-03
GitHub AdvisoriesGHSA-r8hm-p65m-rc9p No score

wp-admin/plugins.php in WordPress before 3.4.2, when the multisite feature is enabled, does not...

wp-admin/plugins.php in WordPress before 3.4.2, when the multisite feature is enabled, does not check for network-administrator privileges before performing a network-wide activation of an installed plugin, which might allow remote authenticated users to make unintended plugin changes by leveraging the Administrator role.

Record
GHSA-r8hm-p65m-rc9p
Updated
2026-11-02
OSV No score

wp-admin/plugins.php in WordPress before 3.4.2, when the multisite feature is enabled, does not check for network-administrator privileges before performing a network-wide activation of an installed plugin, which might allow remote authenticated users to make unintended plugin changes by leveraging the Administrator role.

Record
CVE-2012-4422
Updated
2026-11-02
OSVDEBIAN-CVE-2012-4422 No score

wp-admin/plugins.php in WordPress before 3.4.2, when the multisite feature is enabled, does not check for network-administrator privileges before performing a network-wide activation of an installed plugin, which might allow remote authenticated users to make unintended plugin changes by leveraging the Administrator role.

Record
DEBIAN-CVE-2012-4422
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wordpress
Debian:12
before 3.4.2+dfsg-1
3.4.2+dfsg-1
wordpress
Debian:13
before 3.4.2+dfsg-1
3.4.2+dfsg-1
wordpress
Debian:14
before 3.4.2+dfsg-1
3.4.2+dfsg-1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-4422 is a low vulnerability (CVSS 3.5) in Wordpress, published September 14, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.68%, the 76th percentile. Fixed in wordpress 3.4.2+dfsg-1.

References

MoveEnter Open