Every CVE Search/ Get API key

CVE-2012-4424

Stack-based buffer overflow in string/strcoll_l.c in the GNU C Library (aka glibc or libc6) 2.17...

5.1 MediumFix available

Stack-based buffer overflow in string/strcoll_l.c in the GNU C Library (aka glibc or libc6) 2.17 and earlier allows context-dependent attackers to cause a denial of service (crash) or possibly execute arbitrary code via a long string that triggers a malloc failure and use of the alloca function.

Exploit likelihood

3.38%Up 0.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.1

Stack-based buffer overflow in string/strcoll_l.c in the GNU C Library (aka glibc or libc6) 2.17 and earlier allows context-dependent attackers to cause a denial of service (crash) or possibly execute arbitrary code via a long string that triggers a malloc failure and use of the alloca function.

Record
CVE-2012-4424
CVSS 2.0
5.1 MediumAV:N/AC:H/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Stack-based buffer overflow in string/strcoll_l.c in the GNU C Library (aka glibc or libc6) 2.17 and earlier allows context-dependent attackers to cause a denial of service (crash) or possibly execute arbitrary code via a long string that triggers a malloc failure and use of the alloca function.

Record
CVE-2012-4424
Updated
2026-11-02
EUVDEUVD-2012-4359 No score

Stack-based buffer overflow in string/strcoll_l.c in the GNU C Library (aka glibc or libc6) 2.17 and earlier allows context-dependent attackers to cause a denial of service (crash) or possibly execute arbitrary code via a long string that triggers a malloc failure and use of the alloca function.

Record
EUVD-2012-4359
Updated
2026-11-03
GitHub AdvisoriesGHSA-xmcm-jqgw-pm47 No score

Stack-based buffer overflow in string/strcoll_l.c in the GNU C Library (aka glibc or libc6) 2.17...

Stack-based buffer overflow in string/strcoll_l.c in the GNU C Library (aka glibc or libc6) 2.17 and earlier allows context-dependent attackers to cause a denial of service (crash) or possibly execute arbitrary code via a long string that triggers a malloc failure and use of the alloca function.

Record
GHSA-xmcm-jqgw-pm47
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Stack-based buffer overflow in string/strcoll_l.c in the GNU C Library (aka glibc or libc6) 2.17 and earlier allows context-dependent attackers to cause a denial of service (crash) or possibly execute arbitrary code via a long string that triggers a malloc failure and use of the alloca function.

Record
CVE-2012-4424
Updated
2026-11-02
OSVDEBIAN-CVE-2012-4424 No score

Stack-based buffer overflow in string/strcoll_l.c in the GNU C Library (aka glibc or libc6) 2.17 and earlier allows context-dependent attackers to cause a denial of service (crash) or possibly execute arbitrary code via a long string that triggers a malloc failure and use of the alloca function.

Record
DEBIAN-CVE-2012-4424
Updated
2026-11-02
OSVMGASA-2013-0340 No score

Updated glibc package fixes security vulnerabilities

Updated glibc packages fixes the following security issues:

Integer overflow in string/strcoll_l.c in the GNU C Library (aka glibc or libc6) 2.17 and earlier allows context-dependent attackers to cause a denial of service (crash) or possibly execute arbitrary code via a long string, which triggers a heap-based buffer overflow. (CVE-2012-4412)

Stack-based buffer overflow in string/strcoll_l.c in the GNU C Library (aka glibc or libc6) 2.17 and earlier allows context-dependent attackers to cause a denial of service (crash) or possibly execute arbitrary code via a long string that triggers a malloc failure and use of the alloca function. (CVE-2012-4424)

pt_chown in GNU C Library (aka glibc or libc6) before 2.18 does not properly check permissions for tty files, which allows local users to change the permission on the files and obtain access to arbitrary pseudo-terminals by leveraging a FUSE file system. (CVE-2013-2207) NOTE! This is fixed by removing pt_chown wich may break chroots if their devpts was not mounted correctly. (make sure to mount the devpts correctly with gid=5)

sysdeps/posix/readdir_r.c in the GNU C Library (aka glibc or libc6) 2.18 and earlier allows context-dependent attackers to cause a denial of service (out-of-bounds write and crash) or possibly execute arbitrary code via a crafted (1) NTFS or (2) CIFS image. (CVE-2013-4237)

Multiple integer overflows in malloc/malloc.c in the GNU C Library (aka glibc or libc6) 2.18 and earlier allow context-dependent attackers to cause a denial of service (heap corruption) via a large value to the (1) pvalloc, (2) valloc, (3) posix_memalign, (4) memalign, or (5) aligned_alloc functions. (CVE-2013-4332)

A stack (frame) overflow flaw, which led to a denial of service (application crash), was found in the way glibc's getaddrinfo() function processed certain requests when called with AF_INET6. A similar flaw to CVE-2013-1914, this affects AF_INET6 rather than AF_UNSPEC (CVE-2013-4458).

The PTR_MANGLE implementation in the GNU C Library (aka glibc or libc6) 2.4, 2.17, and earlier, and Embedded GLIBC (EGLIBC) does not initialize the random value for the pointer guard, which makes it easier for context- dependent attackers to control execution flow by leveraging a buffer- overflow vulnerability in an application and using the known zero value pointer guard to calculate a pointer address. (CVE-2013-4788)

Other fixes in this update:

  • Correct the processing of '\x80' characters in crypt_freesec.c
  • drop minimal required kernel to 2.6.32 so it works in chroots on top of enterprise kernels and for OpenVZ users.
  • fix typo in nscd.service
Record
MGASA-2013-0340
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
glibc
Debian:12
before 2.17-94
2.17-94
glibc
Debian:13
before 2.17-94
2.17-94
glibc
Debian:14
before 2.17-94
2.17-94
eglibc
Debian:6.0
From an advisory covering 18 CVEs
before 2.11.3-4+deb6u5, plus listed versions
2.11.2-102.11.2-10+m68k.12.11.2-112.11.2-11+m68k.12.11.2-12
Show 5 moreShow less
2.11.2-132.11.3-12.11.3-22.11.3-32.11.3-4
2.11.3-4+deb6u5
glibc
Mageia:2
From an advisory covering 7 CVEs
before 2.14.1-11.2.mga2
2.14.1-11.2.mga2
glibc
Mageia:3
From an advisory covering 7 CVEs
before 2.17-7.2.mga3
2.17-7.2.mga3

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-4424 is a medium vulnerability (CVSS 5.1) in Gnu Glibc, published October 9, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.38%, the 88th percentile. Fixed in glibc 2.17-94.

References

Show 12 moreShow less
MoveEnter Open